Support the FTP Server "215 NetWare"

RESOLVED FIXED

Status

()

Core
Networking: FTP
--
enhancement
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: Ed Smalley, Assigned: dougt)

Tracking

({qawanted})

Trunk
x86
Windows 2000
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
On our company's intranet site http://macpac.honeywell.com/pal/ I am unable to
FTP anything from our file server to my desktop machine - get error dialog box of:
The FTP server 215 NetWare system type.
is currently unsupported

Other than this problem, I find this product much superior to the other browsers.
Do you know a public ftp server for tests ?

Confirming as enhancement
Severity: critical → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: FTP Server 215 NetWare failure → Support the FTP Server "215 NetWare"

Comment 2

16 years ago
I've looked for this before, no luck so far.
Keywords: qawanted

Updated

16 years ago
Keywords: testcase

Comment 3

16 years ago
Bradley,

'215 NetWare system type.' is essentially equivalent to '215 UNIX Type: L8' 
plus some NetWare specific things that mozilla is never going to use anyway, 
like the ability to switch between namespaces, eg 'QUOTE SITE NFS|LONG|DOS|etc}', 
and of course NDS stuff like 'QUOTE SITE CX <context>'.

Perhaps the (configurable?) ability to ignore 'SYST' would solve such problems.

Comment 4

16 years ago
This report is related to http://bugzilla.mozilla.org/show_bug.cgi?id=95590
If thast the case, then we can just add it to the list. We use the  SYST result
to work out what style directory listings we have.

However, I can't test at the moment - my ISP has installed a 'transparent' FTP
proxy which means I can't use ftp to any server ATM. Hopefully they'll have
cleaned it up later today...

Updated

16 years ago
Keywords: testcase

Comment 6

16 years ago
I've written a routine that parses every known FTP LIST style 
without having to know the SYST. 

The "known" LIST styles is based on what is known to 
squid, lynx, wget, and ftpmirror, and includes:

- VMS (MultiNet, UCX, and CMU) LIST format (including multi-line format)
- IBM VM/CMS, VM/ESA LIST format (two known variants)
- Windows NT's default "DOS-dirstyle"
- OS/2 basic server format LIST format
- SuperTCP FTP Server
- NetManage Chameleon (NEWT)
- EPLF (Easily Parsable List Format)
- '/bin/dls' (two known variants, plus multi-line) LIST format
- '/bin/ls -l' and all variants (even if they are not SYST UNIX)
  including 
   - Hellsoft FTP for NetWare (non-unix perm-bits)
   - Hethmon Brothers FTP for OS/2 (all '-' perm bits)
   - NetPresenz (SYST is "MACOS")
   - "NETWARE" (Hellsoft-style perms, no linkcount, no UID/GID)
   - OpenBSD FTPD (numeric UID/GID)
   - Open Group's FTP servers (no GID)
   - Novonyx [Netscape/Novell] (fields not in columns)
   - wuFTPd and other BSD-based ftpd that exec "ls -l"
   - Windows NT server (internal "ls -l" compatible)
   - Netmanage ProFTPD for Win32 (internal "ls -l" compatible)
   - SurgeFTPd for Win32 (internal "ls -l" compatible)
   - WarFTPd for Win32 (internal "ls -l" compatible)
   - WebStarFTP for MacOS (internal "ls -l" compatible)
   - MurkWorks FTP for NetWare (internal "ls -l" compatible)
   - NcFTPd for Unix (internal "ls -l" compatible).
If there are others, then I'd like to hear about them (send me a sample).

The parser is a complete rewrite (doesn't use anyone else's code),
is thread-safe, does not allocate/free memory, uses only const 
pointers, uses only trivial string.h/ctype.h lib functions, does 
not assume that time_t is 32bit or that a filesize is <= 4GB (or 
even that it is <= 2^64), can deal with servers with Y2K bugs, 
and never mis-parses because it makes NO assumptions about input 
and is (excrutiatingly :) pedantic in its pattern matching. 

It can be downloaded at:
http://fb14.uni-mainz.de/~cyp/moz/ftpbugs/parseLIST.zip

ParseLIST() has been tested against several dozen test-cases, 
twenty-four of which are included in the .zip. 

The .zip file also includes a Win32 'test.exe' for those who 
don't wish to compile but would like beat the parser with their 
own listings.
I have no time to work on mozilla at the moment, so dougt is taking over FTP

open ftp bugs -> him
Assignee: bbaetz → dougt
(Assignee)

Comment 8

16 years ago
new list parser should fix this.
Depends on: 95590
(Assignee)

Comment 9

15 years ago
Fixed via 95590 on trunk
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.