CSS pseudo-element content strings do not display forced line-breaks

VERIFIED INVALID

Status

()

VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: daren, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

Mozilla Browser does not display the line-break special character "\A" in
content strings of CSS pseudo-elements :after and :before.
Maybe Mozilla doesn't render "\A" at all, other special characters (e.g.
Copyright "\A9") work, though.

Related specifications:
(http://www.w3.org/TR/REC-CSS2/generate.html#propdef-content)

Reproducible: Always
Steps to Reproduce:
Open the included page in Mozilla Browser


Actual Results:  The "\A" is rendered as a space.

Expected Results:  The "\A" should be rendered as a newline.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html>
<head>
<title>bug reproduction for line-breaks in pseudo-element content</title>
<meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />
<style type="text/css">
p:before { content:"After this should be a line-break. \A Before this should be
a line-break."; }
p:after { content:"After this should be a line-break. \A Before this should be a
line-break."; }
</style>
</head>
<body>
<p><strong>Paragraph.</strong></p>
</body>
</html>
This is an error in the spec.  The example needs to have 'white-space: pre' as
well.  I belive the need for this was accepted by the working group.  (Ian --
will this be corrected in the next version of CSS already, or do we need to
discuss it?)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Actually reopening since I don't see it fixed in the draft.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
http://www.w3.org/TR/css3-text/#white-space-props says:

   Applies To: all elements and generated content

What more do we need?
so.. we should either confirm this or invalid it again or something.....
Very well.  ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.