Closed Bug 14797 Opened 21 years ago Closed 21 years ago

Messages sent from Unsent folder arrives with the header and msg body in the body and in plain text format

Categories

(MailNews Core :: Backend, defect, P3, major)

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: esther, Assigned: jefft)

Details

Using 19990923 build on win98, (still need to check mac and linux) messages sent
from the Unsent folder using the menu item "Send Unsent Messages" arrives in
mailbox with header and body of message as if your reading the source file.

1. Launch Messenger  (make sure your set for HTML editing )
2. Click New Msg address it to yourself and add HTML attributes to the message
3. Select Send Later from the File menu
4. Check to see if the message is in the Unsent folder and see that the message
body is of the correct HTML format
5. Select Send Unsent Messages from the File menu
6. Select this message from you Inbox (it's missing the subject, a different
bug)
Result:  The message dislplays header and body all in the body in plain text
format with html tags.
OS: other → All
Hardware: PC → All
per pmock, this also occurs on Mac.
Assignee: putterman → rhp
reassigning to rhp
Status: NEW → ASSIGNED
Target Milestone: M11
I see what the problem is...I'll dig into it.

- rhp
Assignee: rhp → jefft
Status: ASSIGNED → NEW
This looks like a problem with "From - " header lines being saved to disk. Jeff
has a beat on this problem.

- rhp
Status: NEW → ASSIGNED
Looks like "From - " header isn't the only problem. I have a fix for the "From -
header" that will be addressed by fixing 10801. The other problem is we did set
the sender of the message when deliver the queued message. We failed in
message_header_sanity_check(). I also have a fix for this.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Problem fixed along with bug 10801. nsMsgSendLater.cpp also changed.
Linux (1999-10-07-08 M11)
Win_nt 4.0 (1999-10-07-08 M11)
This problem is fixed.
Unable to test Mac because of bug 15720
Status: RESOLVED → VERIFIED
Mac (1999-10-26-08 M11)
this problem is fixed on Mac too.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.