Inspect tool shows Value with two percent signs instead of one for progressmeter

VERIFIED FIXED in mozilla1.1alpha

Status

()

Core
Disability Access APIs
P3
minor
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: dsirnapalli, Assigned: Aaron Leventhal)

Tracking

({access})

Trunk
mozilla1.1alpha
x86
Windows 2000
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
<label control="det_progress" value="Determinate Progress Meter:"/>
<progressmeter id="det_progress" mode="determined" value="50%"/>

open Inspect tool, click on "show highlight rectangle button", move the cursor
over the progressmeter. watch value in the inspect tool, you see the value as
"50%%".
When i modify the above code without giving percentage sign(value="50") then
inspect tool shows right value ("50%"). I think you are adding % sign without
checking whether it is already given or not.
I checked xul examples. It's allowed that i can write both the below shown ways
<progressmeter id="det_progress" mode="determined" value="50%"/>
<progressmeter id="det_progress" mode="determined" value="50"/>

Comment 1

16 years ago
it's easy, taking...
Assignee: aaronl → kyle.yuan

Comment 2

16 years ago
aaron said he had already made a patch for this bug.
Assignee: kyle.yuan → aaronl
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Keywords: access
Priority: -- → P3
Target Milestone: --- → mozilla1.1alpha
(Assignee)

Comment 3

16 years ago
Created attachment 85637 [details] [diff] [review]
Does not add extra % sign if one is already there
(Assignee)

Comment 4

16 years ago
Created attachment 85638 [details] [diff] [review]
Does not add extra % sign if already there
Attachment #85637 - Attachment is obsolete: true

Comment 5

16 years ago
Comment on attachment 85638 [details] [diff] [review]
Does not add extra % sign if already there

if (!_retval.IsEmpty() && _retval.Last() != '%')

is more reasonable. 

r=kyle if above fixed
Attachment #85638 - Flags: review+

Comment 6

16 years ago
Comment on attachment 85638 [details] [diff] [review]
Does not add extra % sign if already there

sr=hewitt
Attachment #85638 - Flags: superreview+
(Assignee)

Comment 7

16 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

16 years ago
-- Verified it in todays trunk build. Works fine. Marking bug as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.