Closed Bug 1479778 Opened 3 years ago Closed 3 years ago

Crash in igd10iumd64.dll | static void webrender::renderer::Renderer::draw_color_target (Intel HD Graphics 620)

Categories

(Core :: Graphics: WebRender, defect)

x86_64
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1479795
Tracking Status
firefox63 --- disabled

People

(Reporter: jan, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, nightly-community)

Crash Data

Intel, HD Graphics 620
A different user (compared by addons) of the same graphics card and driver version had a different crash with nearly the same GraphicsCriticalError (bug 1408514 comment 7).

This bug was filed from the Socorro interface and is
report bp-a500870e-6f58-40dc-a820-7da8a0180731.
> EXCEPTION_ACCESS_VIOLATION_WRITE

> |[G0][GFX1-]: GFX: RenderThread detected a device reset in BeginFrame (t=6221.51) |[G1][GFX1-]: Failed to load a program object with a program binary: brush_blend renderer ANGLE (Intel(R) HD Graphics 620 Direct3D11 vs_5_0 ps_5_0)
>  (t=6228.39) |[G2][GFX1-]: Failed program_binary (t=6228.39) |[G3][GFX1-]: Failed to link shader program: brush_blend
> C:\fakepath(536,20-34): warning X3556: integer modulus may be much slower, try using uints if possible.
> C:\fakepath(536,39-53): warning X3556: integer divides may be much slower, try using uints if possible.
> 
> 
> Error allocating VertexShader. HRESULT: 0x8007000E
>  (t=6229.02) 
=============================================================

Top 2 frames of crashing thread:

0 igd10iumd64.dll igd10iumd64.dll@0x8dfde4 
1 xul.dll static void webrender::renderer::Renderer::draw_color_target gfx/webrender/src/renderer.rs:3064

=============================================================
I think based on the crash volumes for non-WebRender, it is a bad driver in general. Tracking in bug 1479795.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1479795
You need to log in before you can comment on or make changes to this bug.