Closed Bug 1479788 Opened Last year Closed Last year

Ars Technica scrolls badly on Intel GPUs

Categories

(Core :: Graphics: WebRender, defect, P2)

63 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1421784
Tracking Status
firefox63 --- affected

People

(Reporter: jrmuizel, Assigned: gw)

References

(Blocks 2 open bugs)

Details

Blocks: wr-intel
See Also: → 1452489
Assignee: nobody → gwatson
Priority: -- → P2
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1421784

I double checked a GPU capture after the mix-blend rewrite got landed, and I see nothing worrying. The red frame indicator is stable most of the time. We end up with around 77 draw calls, not that much pixel work, etc.

I agree - I also checked this page with your MBM changes, and it seemed much better than it used to be.

Yeah it's most impressive, between picture caching and the mix-blend rewrite, arstechnica.com is night & day. On my MacBook Pro scrolling it used to redline my GPU and give about 30 fps at 1280x800. Now today my GPU hardly breaks a sweat and it's butter smooth at 60 fps. Both examples were with an opaque GL context. Well done & thanks!

You need to log in before you can comment on or make changes to this bug.