Closed Bug 1479921 Opened 2 years ago Closed 2 years ago

Recording fails with MacOSFontEntry error

Categories

(Core Graveyard :: Web Replay, defect)

x86_64
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1493482

People

(Reporter: Harald, Unassigned)

Details

STR:
- Enable Tracking Protection (avoid ads that might have video)
- Load https://www.vox.com/science-and-health/2018/7/24/17606958/meat-cheese-surplus-visualized in Recording mode

Site loads enough to be visible, then throws:

Assertion Mismatch: Thread 1
Recorded: CFRelease [67680955,67498]
Replayed: CFRetain ### _ZN7mozilla12recordreplay28AutoRecordReplayFunctionVoid17StartRecordReplayEv ### _ZN7mozilla12recordreplayL11RR_CFRetainEm ### _ZN14MacOSFontEntryC2ERK12nsTSubstringIDsEP6CGFontN7mozilla11WeightRangeENS6_12StretchRangeENS6_15SlantStyleRangeEbb ### _ZN22gfxMacPlatformFontList16MakePlatformFontERK12nsTSubstringIDsEN7mozilla11WeightRangeENS4_12StretchRangeENS4_15SlantStyleRangeEPKhj ### _ZN16gfxUserFontEntry16LoadPlatformFontEPKhRj ### _ZN16gfxUserFontEntry24FontDataDownloadCompleteEPKhj8nsresult ### _ZN16nsFontFaceLoader16OnStreamCompleteEP15nsIStreamLoaderP11nsISupports8nsresultjPKh ### _ZN7mozilla3net14nsStreamLoader13OnStopRequestEP10nsIRequestP11nsISupports8nsresult ### _ZN19nsCORSListenerProxy13OnStopRequestEP10nsIRequestP11nsISupports8nsresult ### _ZN7mozilla3net18nsHTTPCompressConv13OnStopRequestEP10nsIRequestP11nsISupports8nsresult ### _ZN7mozilla3net16HttpChannelChild15DoOnStopRequestEP10nsIRequest8nsresultP11nsISupports ###  [67680955,67498]
Summary: Vox article fails recording with font error → Recording fails with MacOSFontEntry error
Hi, sorry for not replying earlier, I just saw this bug (watching the Web Replay component now, oops).  I just tried both of these sites and am not able to reproduce this problem.  Does it still fail for you on Nightly or a recent m-c build?  If so, I can add some diagnostic asserts (to the ash repository, probably) to see if we can track the problem down.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1493482
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.