Animations tab crashes when timer is set to long values

VERIFIED FIXED in Firefox 63

Status

defect
P1
major
VERIFIED FIXED
Last year
3 months ago

People

(Reporter: cfogel, Assigned: daisuke)

Tracking

({regression})

Trunk
Firefox 63
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 wontfix, firefox62 wontfix, firefox63 verified)

Details

Attachments

(5 attachments)

[Affected versions]:
- 63.0a1 (2018-07-31), 61.0.1, 62.0b13;

[Affected platforms]:
- win 10x64, Ubuntu 16.04LTs, macOS 10.13.4

[Steps to reproduce]:
1. Launch Firefox;
2. Access the following link:
https://rawgit.com/dadaa/3b73f847427025b51ba1ab7333013d0c/raw/77f3f0bb884875a179c3407f73bf8a8dd54751c9/doc_simple_animation.html
3. Open DevTools, Inspector - Animations tab;
4. In the inspector section, click on the <ball negative-delay> div;
5. In the rules section click to modify the animation timer value;
6. Increase the value of the timer adding extra numbers (ex: 10s to 10000000000s or more).

[Expected result]:
- values are added, time-frame indicator is updated. No crashes occur.

[Actual result]:
1. the animations tab and whole right section of the inspector vanishes(including latest beta);

2. on 61.0.1 the whole browser crashes:
- instantly once the value inputed is high enough(nr. of characters)
- if 3-pane is toggled on>off the tab vanishes, ffox doesn't crash fully;
- if about Info window is opened then closed, the browser doesn't crash just 
the inspector right section;


[Regression range]:
- moregression result, after checking strictly after the crashes points out to: 
https://bugzilla.mozilla.org/show_bug.cgi?id=1445825

[Additional notes]:
- attached screen recording with the issues, first part is for nightly/beta behaviour and the second part is for release;
- page refresh, devTools display toggle (or restart) needed to reset the enviroment.
When you notice that a bug is a regression, please use the `regression` keyword.
Keywords: regression
(In reply to Marco Castelluccio [:marco] from comment #1)
> When you notice that a bug is a regression, please use the `regression`
> keyword.

Thanks for the help, I kept forgetting to fill that part.
Thank you for the reporting.
The error was:
  TypeError: 'delay' member of EffectTiming is not a finite floating-point value.
Because 'delay' does not support infinite value[1].
(Also, 'endDelay' and 'iterationStart')

I'll fix this asap.

[1] https://searchfox.org/mozilla-central/source/dom/webidl/AnimationEffect.webidl#29
Assignee: nobody → dakatsuka
Priority: -- → P1
Attachment #8998433 - Flags: review?(gl)
Attachment #8998435 - Flags: review?(gl)
Comment on attachment 8998433 [details]
Bug 1480027 - Part 1: Ignores animations that have big enough delay or endDelay. r=gl

Gabriel [:gl] (ΦωΦ) has approved the revision.
Attachment #8998433 - Flags: review+
Attachment #8998433 - Flags: review?(gl)
Comment on attachment 8998435 [details]
Bug 1480027 - Part 2: Add test for big enough delay and endDelay. r=gl

Gabriel [:gl] (ΦωΦ) has approved the revision.
Attachment #8998435 - Flags: review+
Attachment #8998435 - Flags: review?(gl)
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a90a87e41d89
Part 1: Ignores animations that have overflowed delay or endDelay. r=gl
https://hg.mozilla.org/integration/mozilla-inbound/rev/3f8ddc26081f
Part 2: Add test for overflowed delay and endDelay. r=gl
https://hg.mozilla.org/mozilla-central/rev/a90a87e41d89
https://hg.mozilla.org/mozilla-central/rev/3f8ddc26081f
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
This seems edge-case enough that it can ride the trains, but feel free to nominate for Beta approval if you feel strongly otherwise. Thanks for the automated test too :).
Flags: in-testsuite+
The issue is still present on 63.0a1 (2018-08-13) across platforms (Windows 10 x64, Ubuntu 18.04 x64, macOS 10.13.4).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Iulia Cristescu, QA [:JuliaC] from comment #13)
> The issue is still present on 63.0a1 (2018-08-13) across platforms (Windows
> 10 x64, Ubuntu 18.04 x64, macOS 10.13.4).

I have changed the logic to that if there are overflowing number in delay or end delay field, we ignore the animation displayed. So, in that test case, after changing the delay to big number on the inspector, we can see "No animations ..." message.
I could confirm 63.0a1 (2018-08-13) on OSX 10.13.6.
Could you confirm??
Flags: needinfo?(iulia.cristescu)
I can confirm that the message is still NOT displayed across platforms on 63.0a1 (2018-08-13, using the steps provided in comment 0. For more details, see the screencast https://drive.google.com/file/d/1_OS24jK7QRDxUTUyvva0JFPsCBCC10ny/view?usp=sharing
Flags: needinfo?(iulia.cristescu)
Ah, negative infinity, thanks.
Comment on attachment 9000130 [details]
Bug 1480027 - Part 3: Ignore animations that have negative infinity delay or end delay. r=gl

Gabriel [:gl] (ΦωΦ) has approved the revision.
Attachment #9000130 - Flags: review+
Comment on attachment 9000131 [details]
Bug 1480027 - Part 4: Add test case for negative infinity delay and end delay. r=gl

Gabriel [:gl] (ΦωΦ) has approved the revision.
Attachment #9000131 - Flags: review+
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a2ad987a8861
Part 3: Ignore animations that have negative infinity delay or end delay. r=gl
https://hg.mozilla.org/integration/mozilla-inbound/rev/f2c0be296f6f
Part 4: Add test case for negative infinity delay and end delay. r=gl
https://hg.mozilla.org/mozilla-central/rev/a2ad987a8861
https://hg.mozilla.org/mozilla-central/rev/f2c0be296f6f
Status: REOPENED → RESOLVED
Closed: Last year11 months ago
Resolution: --- → FIXED

Issue verified, filled a separate bug for the newly noticed issue.
(bug 1544688)

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.