Closed Bug 1480086 Opened 2 years ago Closed 2 years ago

Complain by default about invalid CCS rules in CSS rule view of Developer Tools

Categories

(DevTools :: Inspector: Rules, defect, P1)

61 Branch
defect

Tracking

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 wontfix, firefox62 verified, firefox63 verified)

VERIFIED FIXED
Firefox 63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- wontfix
firefox62 --- verified
firefox63 --- verified

People

(Reporter: matkoniecz, Assigned: rcaliman)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image helpful Chromium.png
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180704194937

Steps to reproduce:

Created CSS rule with invalid "padding: 0, 5px, 0px, 5px"


Actual results:

I become confused and started debugging.


Expected results:

CSS rule view should show like in Chromium that rule is invalid
Component: Untriaged → CSS Rules Inspector
Product: Firefox → DevTools
Summary: Complain about invalid CCS rules in CSS rule view of Developer Tools → Complain by default about invalid CCS rules in CSS rule view of Developer Tools
For me the invalid property is struck through but there is no tooltip explaining why.
Strikethrough is also applied to overriden rules so it is quite confusing (initially I thought that it is overridden by a different rule and wasted time on studying documentation of specification of CSS specificity).
To be explicit: I also have property struck through but without any indication that it is caused by an invalid rule.
This functionality does exist (warning icon + message), but it's not visible. The styling for it was accidentally removed along with the Firebug theme in Bug 1378108. It's regressed all the way to stable. Fixing this ASAP and requesting uplift to beta.
Assignee: nobody → rcaliman
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: regression
Priority: -- → P1
Comment on attachment 8996979 [details]
Bug 1480086 - Restore styles for Rule view warning icon.

https://reviewboard.mozilla.org/r/260958/#review268058
Attachment #8996979 - Flags: review?(gl) → review+
See also bug 1410423, which proposes making the warning message more precise depending
on whether the property name or property value is invalid.
> See also bug 1410423, which proposes making the warning message more precise depending
> on whether the property name or property value is invalid.

This was previously fixed in Bug 1411664. Perhaps that other bug can be closed as a duplicate.
Pushed by rcaliman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5619357a1b6a
Restore styles for Rule view warning icon. r=gl
https://hg.mozilla.org/mozilla-central/rev/5619357a1b6a
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Comment on attachment 8996979 [details]
Bug 1480086 - Restore styles for Rule view warning icon.

Approval Request Comment
[Feature/Bug causing the regression]:
https://bugzilla.mozilla.org/show_bug.cgi?id=1480086

[User impact if declined]:
Web developers inspecting their CSS will not see the tooltip with a reason why a CSS property is invalid.

[Is this code covered by automated tests?]:
Yes

[Has the fix been verified in Nightly?]:
Yes

[Needs manual test from QE? If yes, steps to reproduce]: 
Yes, see steps in description of Bug 1480086

[List of other uplifts needed for the feature/fix]:
None

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
Not risky. This functionality existed and regressed a few releases back. It's now regressed as far back as Firefox 62.

[String changes made/needed]:
None
Attachment #8996979 - Flags: approval-mozilla-beta?
Comment on attachment 8996979 [details]
Bug 1480086 - Restore styles for Rule view warning icon.

Fix for regression from 61, let's get the Inspector tooltips working again.
Attachment #8996979 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified, that the issue is no longer reproducible, the CSS Rule Inspector tooltips are displayed on Nightly 63.0a1(20180807100107) and Beta 62.0b15(20180806191531).
Environments covered: Win10 x64, Ubuntu 16.04 and MacOS 10.13.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.