Browser OOM's and hangs with a html file full of emojis, if you drag-and-drop the file from desktop to browser (wrong charset defined). Non-WR

RESOLVED DUPLICATE of bug 1479213

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1479213
10 months ago
10 months ago

People

(Reporter: mayankleoboy1, Unassigned)

Tracking

({perf})

Trunk
Points:
---

Firefox Tracking Flags

(firefox63 affected)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

Reporter

Description

10 months ago
+++ This bug was initially created as a clone of Bug #1479196 +++

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180727231224

Steps to reproduce:



1. create new profile.
2. Download the attachment to your desktop
3. Drag-and-drop the file into the browser
OR
menu bar->file->open file and then browse to the downloaded attachment


Actual results:

Browser memory booms to 5GB+.The tab is unresponsive.  The whole computer may shut down. 


Expected results:

not so

I dont know which component to put this into. Putting it into Layout:Text for the time being.
Reporter

Comment 1

10 months ago
Posted file wrong charset.html
This bug is for the non-WR case
Reporter

Updated

10 months ago
See Also: → 1479196
Reporter

Updated

10 months ago
Severity: critical → normal
Crash Signature: [@ mozilla::ipc::ProcessLink::SendMessageW | IPC_Message_Name=PWebRenderBridge::Msg_SetDisplayList ]
Summary: Browser OOM's and hangs with a html file full of emojis, if you drag-and-drop the file from desktop to browser (wrong charset defined) → Browser OOM's and hangs with a html file full of emojis, if you drag-and-drop the file from desktop to browser (wrong charset defined). Non-WR
Reporter

Comment 2

10 months ago
here is a profile: https://perfht.ml/2AsXvlu
Component: Layout: Text → Graphics: Text
Trying to draw so many missing-glyph hexboxes (as a result of the incorrect encoding) brings the browser to its knees. See also bug 1479213 comment 2; this is just a more extreme example.
Reporter

Comment 4

10 months ago
(In reply to Jonathan Kew (:jfkthame) from comment #3)
> Trying to draw so many missing-glyph hexboxes (as a result of the incorrect
> encoding) brings the browser to its knees. See also bug 1479213 comment 2;
> this is just a more extreme example.

Feel free to mark as a dupe, if you think bug 1479213 is enough to track this issue.
Status: UNCONFIRMED → RESOLVED
Has STR: --- → yes
Last Resolved: 10 months ago
Keywords: perf
Priority: -- → P3
Resolution: --- → DUPLICATE
Whiteboard: [gfx-noted]
Duplicate of bug: 1479213
You need to log in before you can comment on or make changes to this bug.