Enable Windows Restart Manager by default

RESOLVED FIXED in Firefox 62

Status

()

enhancement
P1
normal
RESOLVED FIXED
11 months ago
10 months ago

People

(Reporter: cpeterson, Assigned: agashlin)

Tracking

unspecified
mozilla63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 wontfix, firefox-esr60 wontfix, firefox61 wontfix, firefox62+ verified, firefox63+ fixed)

Details

Attachments

(1 attachment)

Reporter

Description

11 months ago
The Windows Restart Manager is currently #ifdef NIGHTLY_BUILD:

https://searchfox.org/mozilla-central/rev/196560b95f191b48ff7cba7c2ba9237bba6b5b6a/browser/app/profile/firefox.js#1250-1254

We should remove the #ifdef so this feature can ride the trains (in 63 or possibly uplifted to 62).
Assignee

Comment 1

11 months ago
The plan is to study the "restart manager" in 62 with a pref flip,
and if that goes well enable it on release in 63. If it is to be
enabled for the whole population in 63 it needs to ride the trains,
so we'll let it be enabled by default as 63 goes to beta. There will
be time to uplift a backout so it won't reach the release population,
if the 62 study indicates problems.

Updated

11 months ago
Priority: -- → P1

Comment 2

11 months ago
We want to try to do a progressive roll-out in 61.0.2 through Normandy.
We discussed separately over e-mail and slack and the dependencies are:
- Uplift the patches needed in 61.0.2
- Enable the preference in Beta

Adam, per Ritu's message can you please turn the preferences on in Beta62?
Flags: needinfo?(agashlin)
Assignee

Comment 3

11 months ago
Comment on attachment 8996797 [details]
Bug 1480144: Let Windows Restart Manager ride the trains

Approval Request Comment
[Feature/Bug causing the regression]: N/A
[User impact if declined]: Firefox will not restart automatically when Windows restarts for an update.
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: N/A, has been through a QE test cycle already
[List of other uplifts needed for the feature/fix]: None, just turning on a pref by default
[Is the change risky?]: Low risk
[Why is the change risky/not risky?]: Feature has been running on Nightly for three months with no issues reported, rode into beta naturally (though disabled it can still be exercised by tests). The risk mostly comes from users being surprised by the new behavior.
[String changes made/needed]: None
Flags: needinfo?(agashlin)
Attachment #8996797 - Flags: approval-mozilla-beta?
Comment on attachment 8996797 [details]
Bug 1480144: Let Windows Restart Manager ride the trains

Jim Mathies [:jimm] has approved the revision.

https://phabricator.services.mozilla.com/D2620
Attachment #8996797 - Flags: review+
Assignee

Updated

11 months ago
Keywords: checkin-needed
Assignee

Comment 6

11 months ago
(In reply to Adam Gashlin [:agashlin] from comment #5)
> btw here's a clean try run for encouragement:
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=5dd082ea5d69df125337ded47dd147ce8f1cee64

To be clear, that was on central, not beta, sorry for any confusion.

Comment 7

11 months ago
Comment on attachment 8996797 [details]
Bug 1480144: Let Windows Restart Manager ride the trains

There's some discussion on pushing this feature out via staged rollout (using normandy) on 61.0.2 or 62 release train. Either way, this needs to be tested out first on Beta62 and then make a decision re:61.0.2 progressive rollout
Attachment #8996797 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Reporter

Updated

11 months ago
Summary: Let Windows Restart Manager ride the trains → Enable Windows Restart Manager by default
Assignee

Comment 9

11 months ago
I have the uplift prepared over at bug 1480612, didn't want to confused things here.

Comment 10

11 months ago
We tested windows restart manager pref flip (Normandy) on Windows 10 and preview, preview,7 and 8 with beta 62.0b13. The pref, "toolkit.winRegisterApplicationRestart",is set to true(flipped) successfully by Normandy Recipe. We also conducted smoke tests on the feature and it works as intended. All our smoke test runs are green.

Test runs are here- https://testrail.stage.mozaws.net/index.php?/plans/view/11519
Reporter

Comment 11

11 months ago
We uplifted the code to last week's 61.0.2 dot release, disabled by default. Using the Normandy rollout system, we will gradually enable the feature for more users over the coming weeks. The rollout dates are listed in this Trello card's Delivery Checklist above. We enabled the feature for 10% of Windows users on August 13.
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Reporter

Comment 12

11 months ago
Oops. Reopening this bug because Adam handled the 61.0.2 uplift in bug 1480612. This bug is about enabling the Windows Restart Manager pref by default, which will ride in 62.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Reporter

Comment 13

10 months ago
Adam, what needs to be completed to resolve this bug? I thought this feature was enabled by default in 62 and 63, but it looks like the "toolkit.winRegisterApplicationRestart" pref is false in 63 Beta because #ifdef NIGHTLY_BUILD:

https://hg.mozilla.org/releases/mozilla-beta/file/tip/browser/app/profile/firefox.js#l1254
Flags: needinfo?(agashlin)

Comment 14

10 months ago
Pushed by agashlin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fafc1900d5df
Let Windows Restart Manager ride the trains r=jmathies
I'm sorry that I lost track of this, it was turned on in 62 beta but I'd forgotten to land it on mozilla-central. I guess I have to uplift it to beta again.

Speaking of which, as 62 is on its way to release, do we still want this pref on in release by default?
Flags: needinfo?(agashlin)

Comment 16

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/fafc1900d5df
Status: REOPENED → RESOLVED
Closed: 11 months ago10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Reporter

Comment 17

10 months ago
(In reply to Adam Gashlin [:agashlin] from comment #15)
> Speaking of which, as 62 is on its way to release, do we still want this
> pref on in release by default?

Leaving the pref on in 62 is OK. We had some problems with the telemetry analysis of the 61.0.2 pref rollout, so we now plan to start a new pref flip study when 62 ships. By configuring the pref flip study before 62 ships, the experiment system can override the 62's default pref for our control and test groups.

Fortunately, the experiment team can control this all remotely, so you won't need to uplift any code changes to 62. :)
(In reply to Chris Peterson [:cpeterson] from comment #17)
> By configuring the pref flip study before 62 ships, the
> experiment system can override the 62's default pref for our control and
> test groups.
> 
> Fortunately, the experiment team can control this all remotely, so you won't
> need to uplift any code changes to 62. :)

Ok, I'm glad I made sure this pref can be flipped without restart :)

(In reply to Adam Gashlin [:agashlin] from comment #15)
> I guess I have to uplift it to beta again.

This shouldn't be necessary as mozilla-central will continue to be merged to mozilla-beta until the 64 version bump in a few days, so now that it's on (for all builds) in central it should be good to go.
Reporter

Comment 19

10 months ago
(In reply to Adam Gashlin [:agashlin] from comment #18)
> (In reply to Adam Gashlin [:agashlin] from comment #15)
> > I guess I have to uplift it to beta again.
> 
> This shouldn't be necessary as mozilla-central will continue to be merged to
> mozilla-beta until the 64 version bump in a few days, so now that it's on
> (for all builds) in central it should be good to go.

OK. I'll set status-firefox63 from "affected" back to "fixed".
You need to log in before you can comment on or make changes to this bug.