Closed Bug 1480158 Opened 4 years ago Closed 4 years ago

The profile manager no longer updates profile name after a rename, unless it is restarted

Categories

(Toolkit :: Startup and Profile System, defect)

63 Branch
x86_64
All
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- verified

People

(Reporter: poiegas, Assigned: Paolo)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Attached video No rename.mp4
[Affected versions]:
- Nightly 63.0a1

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- Have the latest Nightly build installed / extracted on your computer.
- Have multiple profiles created.

[Steps to reproduce]:
1. Start a Windows Command Prompt window.
2. Locate the folder where Nightly is installed / extracted and drag the "firefox.exe" file into the cmd.
3. After the file path is populated, add " -p -no-remote" after it.
4. Hit "Enter" key and select an existing profile.
5. Click on "Rename Profile" button and enter a different name for it.
6. Click the "OK" button and observe the profile name.

[Expected result]:
- The profile was correctly renamed with the newly entered string.

[Actual results]:
- The profile name remains unchanged.

[Notes]:
- It seems that the rename actually is performed in the directory, but this is not mirrored in the profile manager, only after restarting it.

[Regression]:
- Mozzregression gets me into a loop when trying to find the exact bug but I managed to get some details.
Last good build: 2018-07-09
First bad build: 2018-07-10

Pushlog link: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=b4cd5a640564cee2dda926724bf2faeb8934d702&tochange=12f49235dfd8d8b7330bf6e722ffdc122752ec0d

From these, last good is a34a6f54da75 and first bad is 0b45728b7210. So if I'm not mistaking, the bug that made this to occur is Bug 1472750.
Hey Paolo, I hope I'm not mistaking, but I think one of your changes from Bug 1472750 might have caused this issue. Can you please take a look?
Flags: needinfo?(paolo.mozmail)
Blocks: 1472750
Comment on attachment 8997865 [details]
Bug 1480158 - The profile manager no longer updates the profile name after a rename. r=mak

Marco Bonardo [::mak] (Away 9-26 Aug) has approved the revision.

https://phabricator.services.mozilla.com/D2777
Attachment #8997865 - Flags: review+
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1ca603c55983
The profile manager no longer updates the profile name after a rename. r=mak
https://hg.mozilla.org/mozilla-central/rev/1ca603c55983
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Assignee: nobody → paolo.mozmail
The issue is no longer reproducible on latest Firefox Nightly build (20180807220134). Profile rename is instantly updated in the profile manager.

However, I have one question regarding the rename functionality. If the profile rename only reflects in the manager but not also in the profile folder name, how the user will find his renamed profile folder afterwards if they don't coincide? 
Probably not every user knows about the "Open Folder" button from "about:support" page. 

@Paolo - Do you know anything about this or do you know anyone who I can ask about this?
Status: RESOLVED → VERIFIED
(In reply to Paul Oiegas [:poiegas], Experiments QA from comment #6)
> how the user will find his renamed profile folder afterwards if
> they don't coincide? 

They would have to look for the information in the "profiles.ini" file.

> Probably not every user knows about the "Open Folder" button from
> "about:support" page. 

Since that's accessible from a menu item, there are probably more users who know about the "Open Folder" button than the Profile Manager, or who ever used the rename functionality there :-)
Flags: needinfo?(paolo.mozmail)
Attachment #8997865 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.