whole program freezes temporarily while loading pages

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Timothy Miller, Assigned: Matti)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052316

While loading any page I've tried so far, mozilla will freeze for various
periods of time--the nytimes site in the url seems to be the worst I've found
(can be several seconds or longer) but it seems to happen on every page I've
looked at (mostly including the mozilla.org pages relating to reporting bugs
:-). If this did happen under 0.9.9 (the version I used just prior to my
installing 1.0rc3) then it must have been for a much much briefer period of
time, especially compared to what happens with www.nytimes.com and all the news
articles I looked at on that side. This freeze causes everything in the program
to stop--keyboard and mouse responses as well as window repainting, for all
windows up on the screen--and occurs while the upper right icon activity
indicator is still in its cycling state, though it's not actually cycling while
it's frozen, of course. Now I'm testing it again, the length of the pause seems
much much less now than it had been. This seems to be true even if I start using
the network more like I had been. So, I picked a compromise for the
"reproducibility" field for this bug: the real answer is that the pause is
reproducable every time, but the length of the pause is not reproducible. The
severity I picked is because multithreading is a major feature, even though the
bug seems to have calmed down a lot for me. For what it's worth, I'm on a cable
modem which claims to have 3,000,000 bps downstream and 300,000 bps upstream
bandwidth.

Reproducible: Sometimes
Steps to Reproduce:
1.Load http://www.nytimes.com (or any other page)

Actual Results:  All of mozilla froze during the load, for from a brief to
moderate period of time.

Expected Results:  Mozilla should not have frozen, especially other windows.
Starting from trunk 2002061808 Mozilla freeze on loading any page. During ANY
loading, Mozilla dont allow to change tab or maximize any other Moz window. It's
very annoying. Before this i used trunk from 10th of July and it worked OK.

Platform - Windows 2000
Reproducive - Always

Comment 2

16 years ago
yes i can reproduce this on win98 with mozilla 1.0 final too.
I've asked in the #mozilla irc room about this previously and been 
informed that this is a very hard bug to fix and will probably 
never get fixed. 
Most reviews of mozilla also mention this bug ... its very common
and easily noticeable. it may be a problem with the rendering or 
layout code. it also leads to mozilla feeling "sluggish" to the
user and its probably more cosmetic than anything.

Humm, strange. I didn't had this problem with any older trunk/ver of Mozilla
since 2002061808.
I closed all application, and reopened it once more - at now i cannot reproduce
it. It works OK.
Strange.

For shure Mozilla has problem with creating new tab (ctrl+n) when focus is on
tab which loades. But when i swich tab for something opened i can ctrl+n/ctrl+t .

But this problem with doing anything with Mozilla when anywhere anypage is
loading is very,very annoying. I hope that we can find when it's occure.

As i said, after full restart of Mozilla, it's ok.
WFM with trunk 2002073022, linux. reporter (Timothy Miller): can you reproduce
this bug with a recent build of mozilla (for example, 1.1beta)? if so, please
comment again with details. if not, please resolve this bug as WORKSFORME. thanks.
no answer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.