Closed Bug 14804 Opened 21 years ago Closed 21 years ago

Double-click handling is wrong

Categories

(Core :: XUL, defect, P2)

PowerPC
Mac System 8.5
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: sfraser_bugs, Assigned: sfraser_bugs)

References

Details

(Whiteboard: Fixed)

The way we detect double clicks is incorrect. The main problem is that the
calculation to detect how far the mouse has moved between clicks is broken. This
is because the last mouse position is being updated on mouse moves, as well as
clicks.
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: M11
I'd like to fix this for M11. It solves some usability problems in click handling
in editor, and in tables (mailnews).
Whiteboard: Reviewed fix in hand. Awaiting approval.
Reviewed fix in hand.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Fix checked in.
*** Bug 14627 has been marked as a duplicate of this bug. ***
Whiteboard: Reviewed fix in hand. Awaiting approval. → Fixed
QA Contact: beppe → claudius
Status: RESOLVED → VERIFIED
marking VERIFIED based on reproter/developer comments.
You need to log in before you can comment on or make changes to this bug.