Closed Bug 148048 Opened 20 years ago Closed 6 years ago

waas.stanford.edu - Framset will not display -- will in IE >= 5.x

Categories

(Web Compatibility :: Desktop, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: lohphat, Unassigned)

References

()

Details

win32 2002052908 build cannot display URL
Marking NEW for the fact, that it is happening. I am not sure this is a bug, though.

Opening the page results into several JS errors:
Error: PPTSld.document.all has no properties
Source File: http://waas.stanford.edu/LAASsummary_files/script.js
Line: 60
Error: OtlObj is not defined
Source File: http://waas.stanford.edu/LAASsummary_files/outline.htm
Line: 42
Error: invalid return
Source File: http://waas.stanford.edu/LAASsummary_files/slide0007.htm
Line: 39, Column: 20
Source Code:
if( !IsSldOrNts() ) return;
Error: invalid return
Source File: http://waas.stanford.edu/LAASsummary_files/slide0007.htm
Line: 39, Column: 20
Source Code:
if( !IsSldOrNts() ) return;
Error: document.all has no properties
Source File: http://waas.stanford.edu/LAASsummary_files/script.js
Line: 469
Error: nav_text is not defined
Source File: http://waas.stanford.edu/LAASsummary_files/outline.htm
Line: 132

As usual with IE-optimized pages, there is no DOCTYPE. Trying to validate as
HTML 4.01 Frameset:
http://validator.w3.org/check?uri=http%3A%2F%2Fwaas.stanford.edu%2FLAASsummary_files%2Fframe.htm&charset=%28detect+automatically%29&doctype=HTML+4.01+Frameset
Mainly, <![if !ppt]> is not allowed.

pi
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Bulk moving P1-P5 un-milestoned bugs to future. 
Target Milestone: --- → Future
It is not Mozilla's fault, it's just code that only msie understands. When msie
proprietary code is used, then only msie will render the page as desired.

Apparently, some of the server-parsed code didn't get parsed. How should the
browser read and display a page with code like this? There are no guarantees for
such code. 

<link rel=Preview href=preview.wmf>
<title>LAAS Progress Update and FY 2001 Program Plan</title>
<![if !ppt]><script src=script.js></script><script>
<!--
var gNavLoaded = gOtlNavLoaded = gOtlLoaded = false;
function Load()
{
	str=document.location.hash,idx=str.indexOf('#')
	if(idx>=0) str=str.substr(1);
	if(str) PPTSld.location.replace(str);
}
//-->
</script><![endif]>

This is evang.  The page is using multiple IE-isms; there is no way it can work
in Mozilla as-is...
Assignee: john → english-us
Component: Layout: HTML Frames → English US
Priority: P3 → --
Product: Browser → Tech Evangelism
QA Contact: amar → english-us
Target Milestone: Future → ---
Version: Trunk → unspecified
Summary: Framset will not display -- will in IE >= 5.x → waas.stanford.edu - Framset will not display -- will in IE >= 5.x
Issue still exists.
Assignee: english-us → nobody
Component: English US → Desktop
Site appears to no longer exist, closing.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.