Payment failure string does not respect spec.

RESOLVED DUPLICATE of bug 1470207

Status

()

defect
RESOLVED DUPLICATE of bug 1470207
9 months ago
9 months ago

People

(Reporter: timea.babos, Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox63 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 months ago
[Affected versions]:
Nightly 63.0a1

[Affected platforms]:
Windows 10 x64, Ubuntu 16.04, Mac OS 10.13

[Prerequisites]:
- set the pref dom.payments.request.enabled to "true"
- have a profile with saved cards

[Steps to reproduce]:
1. Go to “https://bugzilla.mozilla.org/attachment.cgi?id=8988961” and click on “Pay(fail)” button
2. Select a payment method and fill in the CVV code
3. Click on “Pay” button

[Expected Result]:
The failure error screen is displayed with the first suggestion: “ Check that your credit card is not expired” as per https://mozilla.invisionapp.com/share/SDFY4PA4EQ7#/screens/304878932

[Actual Result]:
The failure error screen appears with the incorrect suggestion: “Check your credit card has not expired”.

[Notes]
Every suggestion from both the failure and timeout screens end with a dot although in the spec. document they do not.
Flags: qe-verify+
(Reporter)

Updated

9 months ago
Whiteboard: [webpayments] [triage]
(Reporter)

Updated

9 months ago
Flags: needinfo?(jaws)
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(jaws)
Resolution: --- → DUPLICATE
Duplicate of bug: 1470207
Whiteboard: [webpayments] [triage]
You need to log in before you can comment on or make changes to this bug.