Credit card form billing address validation and layout

VERIFIED FIXED in Firefox 64

Status

()

defect
P1
normal
VERIFIED FIXED
10 months ago
7 months ago

People

(Reporter: timea.babos, Assigned: MattN)

Tracking

(Depends on 1 bug, Blocks 1 bug)

Trunk
Firefox 64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 verified)

Details

(Whiteboard: [webpayments])

Attachments

(1 attachment)

Reporter

Description

10 months ago
[Affected versions]:
Nightly 63.0a1

[Affected platforms]:
Windows 10 x64, Ubuntu 16.04, Mac OS 10.13

[Prerequisites]:
- set the pref dom.payments.request.enabled to "true"
- have a profile with saved cards

[Steps to reproduce]:
1. Go to “https://rsolomakhin.github.io/pr/single/” and click on “Buy” button
2. Select a saved shipping address
3. Click on “Add” link for a new Credit Card
4. Fill all the field with valid data, except billing address – select the blank option for it
5. Click on “Add” button
6. Type in the CVV code and click on “Pay”

[Expected Result]:
The “Add” button from the Add Credit Card screen should be grayed out if the billing address is missing.
The Payment should be processed only when all the fields from Credit Card are filled.

[Actual Result]:
The payment will be processed without the billing address for the selected card.
Flags: qe-verify+

Updated

10 months ago
Priority: -- → P2
Whiteboard: [webpayments] [triage] → [webpayments-reserve]
Reminder to add the asterisk to the field(s) when making it required.
Whiteboard: [webpayments-reserve] → [webpayments]
I'll take this bug and also use it to make the billing address and persist checkbox position match the specs.
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Priority: P2 → P1
Attachment #9003660 - Attachment description: Bug 1480717 - Fix credit card form billing address and persist checkbox layout. → Bug 1480717 - Fix credit card form billing address and persist checkbox layout. r=sfoster
If there are no review issues, feel free to autoland this.
Comment on attachment 9003660 [details]
Bug 1480717 - Fix credit card form billing address and persist checkbox layout. r=sfoster

Sam Foster [:sfoster] has approved the revision.
Attachment #9003660 - Flags: review+

Comment 8

8 months ago
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/32d9dbdfae6b
Fix credit card form billing address and persist checkbox layout. r=sfoster
Summary: Credit card form can be saved without a billing address → Credit card form billing address validation and layout

Comment 9

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/32d9dbdfae6b
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64

Comment 10

8 months ago
Verified as fixed on Firefox Nightly 64.0a1 on Windows 10 x 64, Windows 7 x32, Mac OS X 10.13 and Ubuntu 18.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Duplicate of this bug: 1492763
You need to log in before you can comment on or make changes to this bug.