Closed Bug 1480888 Opened Last year Closed Last year

Implement blocking system for special search shortcut top sites

Categories

(Firefox :: New Tab Page, enhancement, P1)

57 Branch
enhancement

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.4 - Aug 20
Tracking Status
firefox62 --- verified
firefox63 --- verified

People

(Reporter: ursula, Assigned: ursula)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [fxsearch])

Attachments

(2 files)

The following blocking behaviour applies to the special search shortcut top sites:
1. Once the places query for top sites returns all links, find any link with hostname `amazon` or `google` and change it to be `www.amazon.com` or `www.google.com` or some generic amazon and google link that we decide
2. When blocking the special search shortcut top site via 'Dismiss' option in context menu, it blocks the generic version of the link associated with the special search shortcut top site, so that next time, any amazon/google link that comes out of places organically gets changed to it's generic link version via step 1, and will get filtered out. This results in never showing another special search shortcut top site for that provider

The idea here is that instead of showing, for example an amazon top site, it'll *always* show the special search shortcut, unless the user has attempted to block the special search shortcut tile, in which case we never show any amazon links, and we never show the special search shortcut tile either. If they have blocked the special search shortcut tile, it's a good indicator that they never want to see a tile of that sort again. If they want to see an amazon link again, they can add it manually using the 'add a top site' functionality.


.... I think I've got this right, Kate/Aaron if I've missed anything or misunderstood anything, please fill in the blanks!
"associated with" in this case should be matching the hostname field, (i.e. "amazon", "google")
Severity: normal → enhancement
Iteration: --- → 63.4 - Aug 20
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/87c9130d5c710000a404c37b38afc0a5bda9dda3
Bug 1480888 - Implement blocking system for special search shortcut top sites - Part 1

https://github.com/mozilla/activity-stream/commit/3582df595a335c73a85078971f7fdd7081f62a80
Merge pull request #4299 from sarracini/bug_1480888

Bug 1480888 - Implement blocking system for special search shortcut top sites - Part 1
Priority: P2 → P1
Comment on attachment 8998937 [details]
Bug 1480888 - Implement blocking system for special search shortcut top sites

Kate Hudson :k88hudson has approved the revision.
Attachment #8998937 - Flags: review+
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d103f117bb84
Implement blocking system for special search shortcut top sites r=k88hudson
Will fix this test failure and re-land
Flags: needinfo?(usarracini)
Pushed by usarracini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/44e1ccd1d22b
Implement blocking system for special search shortcut top sites r=k88hudson
Backout by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/606d6089dd02
Backed out changeset 44e1ccd1d22b for xpcshell failure on toolkit/modules/tests/xpcshell/test_CanonicalJSON.js. CLOSED TREE
Third time's the charm! Will fix this once and for all, and then re-land. Sorry about all the backouts
Flags: needinfo?(usarracini)
Pushed by usarracini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e623335f5413
Implement blocking system for special search shortcut top sites r=k88hudson
https://hg.mozilla.org/mozilla-central/rev/e623335f5413
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Blocks: 1482398
Whiteboard: [fxsearch]
I have verified that the issue is no longer reproducible in the latest Nightly (63.0a1, Build ID 20180816100035) and Beta (62.0b18 Build ID 20180816151750) on Windows 10, Mac 10.13 and Arch Linux x64. A new Google or Amazon Top Site is not generated once the search shortcuts are dismissed.
Status: RESOLVED → VERIFIED
Blocks: 1504764
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.