Implement ability to bookmark a selection of tabs through drag and drop

VERIFIED FIXED in Firefox 64

Status

()

enhancement
P1
normal
VERIFIED FIXED
Last year
9 months ago

People

(Reporter: reqqxn, Assigned: jaws)

Tracking

(Blocks 1 bug)

unspecified
Firefox 64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 verified)

Details

(Whiteboard: [blocking-multiselect-tabs])

Attachments

(1 attachment)

Dragging and dropping a selection of tabs to bookmark bar/sidebar/etc should bookmark each tab in selection.
Blocks: 1458007
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Whiteboard: [blocking-multiselect-tabs]
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Priority: P3 → P1
Comment on attachment 9004986 [details]
Bug 1480907 - Implement ability to bookmark a selection of tabs through drag and drop. r?Felipe

:Felipe Gomes (needinfo me!) has approved the revision.
Attachment #9004986 - Flags: review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c8d6a8dca44d
Implement ability to bookmark a selection of tabs through drag and drop. r=Felipe
Backed out for failures on browser_multiselect_tabs_reorder.js

backout: https://hg.mozilla.org/integration/autoland/rev/ec1279ae74f332a9b7fa33cbb365a92c7d12b940

push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=c8d6a8dca44d819667a0cacfed8f0b3f411e4bc5&selectedJob=196770394

failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=196770394&repo=autoland&lineNumber=2442

15:52:41     INFO - TEST-PASS | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Tab1 is active - 
15:52:41     INFO - TEST-PASS | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Three selected tabs - 
15:52:41     INFO - TEST-PASS | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Tab1 is multiselected - 
15:52:41     INFO - TEST-PASS | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Tab3 is multiselected - 
15:52:41     INFO - TEST-PASS | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Tab5 is multiselected - 
15:52:41     INFO - TEST-PASS | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Tab0 is not multiselected - 
15:52:41     INFO - TEST-PASS | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Tab2 is not multiselected - 
15:52:41     INFO - TEST-PASS | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Tab4 is not multiselected - 
15:52:41     INFO - TEST-PASS | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Tab0 position is :0 - 
15:52:41     INFO - TEST-PASS | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Tab1 position is :1 - 
15:52:41     INFO - TEST-PASS | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Tab2 position is :2 - 
15:52:41     INFO - TEST-PASS | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Tab3 position is :3 - 
15:52:41     INFO - TEST-PASS | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Tab4 position is :4 - 
15:52:41     INFO - TEST-PASS | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Tab5 position is :5 - 
15:52:41     INFO - Buffered messages finished
15:52:41     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Uncaught exception - Waiting for tab position to be updated - timed out after 50 tries.
15:52:41     INFO - Leaving test bound 
15:52:41     INFO - GECKO(914) | MEMORY STAT | vsize 4474MB | residentFast 382MB | heapAllocated 95MB
15:52:41     INFO - TEST-OK | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | took 6319ms
15:52:41     INFO - Not taking screenshot here: see the one that was previously logged
15:52:41     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Found an unexpected tab at the end of test run: http://mochi.test:8888/ - 
15:52:41     INFO - Not taking screenshot here: see the one that was previously logged
15:52:41     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Found an unexpected tab at the end of test run: http://mochi.test:8888/ - 
15:52:41     INFO - Not taking screenshot here: see the one that was previously logged
15:52:41     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Found an unexpected tab at the end of test run: http://mochi.test:8888/ - 
15:52:41     INFO - Not taking screenshot here: see the one that was previously logged
15:52:41     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Found an unexpected tab at the end of test run: http://mochi.test:8888/ - 
15:52:41     INFO - Not taking screenshot here: see the one that was previously logged
15:52:41     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/tabs/browser_multiselect_tabs_reorder.js | Found an unexpected tab at the end of test run: http://mochi.test:8888/ - 
15:52:41     INFO - checking window state
Flags: needinfo?(jaws)
Flags: needinfo?(jaws)
Felipe, I had to make some changes to fix the test failure.

Here's the interdiff: https://phabricator.services.mozilla.com/D4589?vs=11997&id=12986&whitespace=ignore-most#toc
The changes are in the _getDropEffectForTabDrag function.
Flags: needinfo?(felipc)
Looks good
Flags: needinfo?(felipc)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7056aff16fb8
Implement ability to bookmark a selection of tabs through drag and drop. r=Felipe
https://hg.mozilla.org/mozilla-central/rev/7056aff16fb8
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
I have reproduced this bug with Nightly 63.0a1 (2018-08-08) on Windows 10, 64 Bit!
This bug's fix is verified with latest Nightly!

Build ID   - 20180910220142
User Agent - Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64
QA Whiteboard: [bugday-20180905]
I opening this bug.

I was not able to bookmark selected tabs/single tab via drag and drop in Private Browsing Mode.

Build ID 	20181003100127
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Damira Akh from comment #10)
> I opening this bug.
> 
> I was not able to bookmark selected tabs/single tab via drag and drop in
> Private Browsing Mode.
> 
> Build ID 	20181003100127
> User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0)
> Gecko/20100101 Firefox/64.0

Please keep this bug marked as resolve-fixed since patches have landed. If you cannot verify the bug then please file a new one. We usually only reopen a bug if the patch that landed got backed out.

That said, I am able to verify that drag/drop bookmarks the page. Here are my steps to reproduce:
1. Using a local build based off mozilla-central from 10/1/2018, open Firefox and then open a private window.
2. In the private window, right click on the navigation toolbar and check the Bookmarks Toolbar menuitem so the Bookmarks Toolbar will appear.
3. Open a new tab and load google.com in the new tab.
4. Open a new tab and load facebook.com in the new tab.
5. Ctrl-click on the google.com tab so both facebook.com and google.com tabs are selected.
4. Drag the google.com tab to the Bookmarks toolbar, wait until you see a dropmarker appear and release the mouse button.

google.com and facebook.com should now appear in the bookmarks toolbar in both the private and non-private window.

What are your steps to reproduce in that you are not able to bookmark via drag and drop?
Status: REOPENED → RESOLVED
Closed: Last year11 months ago
Flags: needinfo?(dakhmedova)
Resolution: --- → FIXED
Flags: needinfo?(dakhmedova)
Verified with 64.0b8 and 65.0a1 (2018-11-11) on Win10, macOS10.13, Ubuntu16.04.
Can also confirm that the changes are ok with private browsing.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.