Missing "Mozilla FTP server" link in README.txt to moz-central

VERIFIED FIXED in Firefox 65

Status

()

defect
P2
normal
VERIFIED FIXED
10 months ago
4 months ago

People

(Reporter: suriyaa, Assigned: suriyaa)

Tracking

Trunk
mozilla65
Points:
---

Firefox Tracking Flags

(firefox65 verified)

Details

Attachments

(2 attachments)

Assignee

Description

10 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180802174131

Steps to reproduce:

- Read the README.txt file at https://dxr.mozilla.org/mozilla-central/source/README.txt.
- Link is missing for "Mozilla FTP server" in line 21: https://dxr.mozilla.org/mozilla-central/source/README.txt#21.


Actual results:

Link for "You can download nightly development builds from the Mozilla FTP server." is not available.


Expected results:

Include this link in README.txt: https://ftp.mozilla.org/pub/firefox/nightly/.
Assignee

Comment 1

10 months ago
I'm working on this bug.
Assignee

Updated

10 months ago
Attachment #8997668 - Flags: review?(dao+bmo)
Attachment #8997668 - Flags: review?(bzbarsky)
Assignee

Updated

10 months ago
Attachment #8997668 - Flags: review?(mmorris)
Assignee

Updated

10 months ago
Attachment #8997668 - Flags: review?(dvarga)
Attachment #8997668 - Flags: review?(aciure)

Comment 3

10 months ago
mozreview-review
Comment on attachment 8997668 [details]
Bug 1480997 - Add missing "Mozilla FTP server" link in README.txt.

https://reviewboard.mozilla.org/r/261358/#review268456

The link to https://archive.mozilla.org/pub/firefox/nightly/latest-mozilla-central/ seems sufficient.
Attachment #8997668 - Flags: review?(dao+bmo) → review-

Updated

10 months ago
Attachment #8997668 - Flags: review?(mmorris)
Attachment #8997668 - Flags: review?(dvarga)
Attachment #8997668 - Flags: review?(bzbarsky)
Attachment #8997668 - Flags: review?(aciure)
Assignee

Comment 4

10 months ago
mozreview-review-reply
Comment on attachment 8997668 [details]
Bug 1480997 - Add missing "Mozilla FTP server" link in README.txt.

https://reviewboard.mozilla.org/r/261358/#review268456

Well the archive link is sufficient for the "Keep in mind that nightly builds, which are used by Mozilla developers for testing, may be buggy" sentence.
In my opinion the FTP link would be very useful for the "You can download nightly development builds from the Mozilla FTP server" clause.

(PS: This is my first commit on mozilla-central!)
I thought we had a goal of limiting the exposure of ftp.mozilla.org because it's not load-balanced.  Is that not the case anymore?
Flags: needinfo?(ehumphries)
(In reply to Suriyaa Sundararuban [:suriyaa] from comment #4)

> In my opinion the FTP link would be very useful for the "You can download
> nightly development builds from the Mozilla FTP server" clause.

Hi, we're no longer listing the FTP server as a source for builds, as :bzbarsky noted above in comment #5.

Would you resubmit the patch, removing line #21 of the current revision, which refers to the FTP server?

The two https links at the bottom are the preferred location to obtain nightlies.

Thank you.
Flags: needinfo?(ehumphries) → needinfo?(mozilla)
P2 because it's being worked on.
Priority: -- → P2
Assignee

Comment 8

7 months ago
Removing the FTP server listing in README.txt
Assignee

Comment 9

7 months ago
Done.
Flags: needinfo?(overholt)
Flags: needinfo?(mozilla)
Flags: needinfo?(dtownsend)
Flags: needinfo?(dao+bmo)
You generally only need to request review from one person and you don't need to also needinfo them on the bug.
Flags: needinfo?(overholt)
Flags: needinfo?(dtownsend)
Flags: needinfo?(dao+bmo)
Assignee

Comment 11

7 months ago
Ok.
Assignee: nobody → mozilla

Comment 12

7 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/480b34db3172
Remove "Mozilla FTP server" link in README.txt r=mossop

Comment 13

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/480b34db3172
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
QA Whiteboard: [good first verify]

I can confirm that the FTP listing is no more present in the mozilla-central README.txt location. Also, the final warning from the targeted documentation is successfully displayed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.