Starting new instance on remote X fails when already running locally

RESOLVED DUPLICATE of bug 135137

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 135137
16 years ago
13 years ago

People

(Reporter: Chris Ross, Assigned: Matti)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052309

Logging in from a remote machine and starting a new instance of Mozilla used to
work fine up until Release Candidate 3. Now it fails with profile in use error.
I use this a lot so that I can get access to all my bookmarks and such.

Reproducible: Always
Steps to Reproduce:
1. Have Mozilla RC3 running locally (Linux)
2. Go to another PC, telnet in to "home" PC
3. execute "/usr/local/mozilla/mozilla"

Actual Results:  "Choose a Profile" dialog appears. It has only one entry,
choose it. Mozilla refuses to start because it's already in use.

Expected Results:  All versions of Mozilla prior to RC3 started normally,
displaying on the remote X display. Of course, preference changes can be lost in
one or other session but this is not a problem. Generally you don't change
preferences every session, and it's easy to live with restrictions on what you
can do in the remote session.

Comment 1

16 years ago
not a problem related to data transport.

Maybe profiles?
Assignee: new-network-bugs → Matti
Component: Networking → Browser-General
QA Contact: benc → imajes-qa
Preference changes are not nearly the issue that cache, history, bookmarks, 
etc. are.  We were seeing a lot of profile corruption before this change went 
in.

Dup of "Profile data cannot be shared by multiple running instances."

*** This bug has been marked as a duplicate of 135137 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.