Closed Bug 1481085 Opened 3 years ago Closed 3 years ago

Firefox ignore the network.captive-portal-service.enabled preference, polls anyway

Categories

(Core :: Networking, defect, P3)

61 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: arnobugs, Assigned: valentin)

References

(Blocks 1 open bug)

Details

(Whiteboard: [necko-triaged])

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180704003137

Steps to reproduce:

about:config

network.captive-portal-service.enabled set to false
captivedetect.canonicalURL set to ""

OS: Win7 32bit
FF: 61.0.1
Language OS/FF: Dutch (is this relevant for non UI bugs?)


Actual results:

Still traffic to detectportal.firefox.com



Expected results:

No traffic
Component: Untriaged → Networking
Product: Firefox → Core
Valentin, any ideas?
Flags: needinfo?(valentin.gosu)
Priority: -- → P3
Whiteboard: [necko-triaged]
(In reply to Arno from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; rv:61.0) Gecko/20100101 Firefox/61.0
> Build ID: 20180704003137
> 
> Steps to reproduce:
> 
> about:config
> 
> network.captive-portal-service.enabled set to false
> captivedetect.canonicalURL set to ""

Did you restart the browser after performing these steps?
How did you verify that there is traffic still happening? Wireshark or something else?
Flags: needinfo?(valentin.gosu)
Assignee: nobody → valentin.gosu
I restart the computer once a day or so. And it is not only recently.
For ad blocking I use pihole and blacklisted detectportal.firefox.com
The url shows in blocked domains.
(In reply to Arno from comment #3)
> I restart the computer once a day or so. And it is not only recently.
> For ad blocking I use pihole and blacklisted detectportal.firefox.com
> The url shows in blocked domains.

Btw, can you verify this with a new profile?
One reason you might be still seeing connections to detectportal is that you have it in your recent history/new page thumbnails.
Trying it out with a new profile would verify if this is because of the captive portal detection or not.

If it still happens in a new profile (with the about:config preferences changed as you describe in comment 0) I will ask you to gather some logs as per the instructions here [1]. Change the log modules string to timestamp,sync,CaptivePortalService:5

Thanks!


[1]https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging#Using_aboutnetworking
New profile is OK.

In old profile I deleted files in thumbnails folder (not of captivedetect.canonicalURL but other sites) and that stopped the network traffic.
I expected it to be an on/off switch but there was more to the story.

Thanks.
Thanks for confirming. I'm glad to know that the captive portal service is working as expected.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.