Closed Bug 1481398 Opened 4 years ago Closed 3 years ago

The page http://m.tmz.com/#!2018/08/06/mighty-ducks-goalie-shaun-weiss-arrested-mug-shot/ is entirely black while Tracking Protection Basic is enabled

Categories

(Web Compatibility :: Desktop, defect, P3)

Firefox 62
x86_64
Windows 10
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1609867

People

(Reporter: oanaarbuzov, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [webcompat][tp-ads][tp-content])

User Story

bkrtx.com
kaltura.com
youtube.com

Attachments

(3 files)

Attached image Screenshot_4.png
[Environment:]
Browser / Version: Firefox Nightly 63.0a1 (2018-08-06)
Operating System: Windows 10 Pro

[Prerequisites:]
    1. Tracking Protection Basic enabled.
[Steps to Reproduce:]
    1. Navigate to http://m.tmz.com/#!2018/08/06/mighty-ducks-goalie-shaun-weiss-arrested-mug-shot/
    2. Observe the page
        
[Expected Behavior:]
The page’s content is loaded. 
 
[Actual Behavior:]
Page is black.

[Notes:]
1. Also reproducible on mobile.
This is related to `tracking protection` breakage.

Looking at the devtools console, here are the blocked resources:
The resource at “http://tags.bkrtx.com/js/bk-coretag.js” was blocked because tracking protection is enabled.
The resource at “http://static.criteo.net/js/ld/publishertag.js” was blocked because tracking protection is enabled.
The resource at “http://ad.doubleclick.net/ddm/ad/gcwzow/pnvsrl/zlzxpqbgc/pl/;ord=1533627989734?” was blocked because tracking protection is enabled.

So there were domains to test:
- tags.bkrtx.com
- static.criteo.net
- ad.doubleclick.net

I opened the URL in a fresh browser profile (Firefox Nightly 63, uMatrix installed, normal mode) and loaded the page. The page is black.

I disabled the Spoof Referrer option in uMatrix and then WHITELISTED:
- tags.bkrtx.com 
- cdnapi.kaltura.com
and the page content loaded with the exception of the YouTube embedded video.

This part is related to `tpvideo` breakage (https://bugzilla.mozilla.org/showdependencytree.cgi?id=1400025&hide_resolved=1).

To make the video player be displayed and to play the video, I whitelisted: 
- googlevideos.com (and all related domains) 
- youtube.com (and all related domains)
 
The other resources (static.criteo.net, ad.doubleclick.net) didn't help. 

So in conclusion:
- bkrtx.com – Advertising = [tp-ads]
- kaltura.com - Content = [tp-content]
- youtube.com - Content = [tp-content]
- googlevideos.com - not listed in Blacklist or Google mapping, but shows as a Google Resource in Entitylist.
User Story: (updated)
Attached image Screenshot_3.png
Added uMatrix results to displayed the page content.
Attached image Screenshot_7.png
Added uMatrix results to display the video player and play the video.
Product: Tech Evangelism → Web Compatibility

Migrating Webcompat whiteboard priorities to project flags. See bug 1547409.

Webcompat Priority: --- → ?

See bug 1547409. Migrating whiteboard priority tags to program flags.

Webcompat Priority: ? → ---

Aside from instagram embedded videos not appearing in strict mode (just a link in their stead), the page seems to be working fine (including other videos). The instagram issue is bug 1609867, so I'll close this as a dupe.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1609867
You need to log in before you can comment on or make changes to this bug.