rename nsAttrAndChildArray

RESOLVED FIXED in Firefox 63

Status

()

enhancement
RESOLVED FIXED
Last year
Last year

People

(Reporter: smaug, Assigned: smaug)

Tracking

unspecified
mozilla63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 fixed)

Details

Attachments

(2 attachments)

Assuming the change to use nsAttrAndChildArray only for attrs won't be backed out, we should rename it to AttrArray or some such.
Blocks: 1481501
bug 1469521 landed recently, and assuming there are no too bad regressions, we should start to clean up the code a bit. This is the first bit.
Only renaming and some minor coding style fixes.
Try push is in bug 1481501
Attachment #8998233 - Flags: review?(mrbkap)
Comment on attachment 8998233 [details] [diff] [review]
attrarray.diff

Review of attachment 8998233 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/html/nsGenericHTMLElement.cpp
@@ +113,5 @@
>  
>    bool reparse = (aDst->OwnerDoc() != OwnerDoc());
>  
> +  rv = static_cast<nsGenericHTMLElement*>(aDst)->mAttrs.
> +       EnsureCapacityToClone(mAttrs, aPreallocateChildren);

This indentation is weird.
Attachment #8998233 - Flags: review?(mrbkap) → review+
it is. I can fix that existing weirdness while I'm there.
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3f144275839d
rename nsAttrAndChildArray to AttrArray, r=mrbkap
https://hg.mozilla.org/mozilla-central/rev/3f144275839d
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
You need to log in before you can comment on or make changes to this bug.