Closed Bug 1481413 Opened 3 years ago Closed 3 years ago

Could not change calendar starting of week to monday

Categories

(Calendar :: General, defect)

Lightning 6.2
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1473294

People

(Reporter: helmut.schuett, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.84 Safari/537.36

Steps to reproduce:

Updated to Version 60.0 x64 on Windows.



Actual results:

If I change "starting day of week" in calendar settings to monday it works only until I restart Thunderbird. Then sunday is set as "starting day of the week" (which is the default setting)


Expected results:

The setting "monday as starting day of the week" should be stored in my preferences
Summary: Could not change calendard starting on monday → Could not change calendar starting of week to monday
manually setting 
user_pref("calendar.week.start", 1);
in prefs.js solves the problem.
But it cannot be changed in GUI.
Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 60 → Lightning 6.2
We just have reports about the resetting, but not about not being able to change it manually.

I can confirm this happens when using a new profile. However, repeating it using the UI, the pref value is persisted also across restart. This seems to be another aspect to deal with in bug 1473294.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter, are you using the German version of Thunderbird? I you are, I think I understand what's causing this.

Also, does it work with a different day of the week?
Flags: needinfo?(helmut.schuett)
Yes I'm using german version
Flags: needinfo?(helmut.schuett)
Setting to another day then Monday works flawlessly here on a German version.
I'm fairly certain this will be fixed by bug 1473294, which will also set the default back to Monday for German users.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1473294
You need to log in before you can comment on or make changes to this bug.