Closed Bug 1481420 Opened Last year Closed Last year

Port bug 1476088 - TEST-UNEXPECTED-FAIL | toolkit/components/search/tests/xpcshell/test_sendSubmissionURL.js

Categories

(Thunderbird :: General, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 63.0

People

(Reporter: jorgk-bmo, Assigned: mkaply)

Details

(Whiteboard: [Thunderbird-testfailure: X all])

Attachments

(1 file)

Bug 1476088 introduced toolkit/components/search/tests/xpcshell/test_sendSubmissionURL.js which fails for TB:
https://hg.mozilla.org/mozilla-central/rev/fb85f9a81670722ca0de657cdad944b342585a79#l2.3

TEST-UNEXPECTED-FAIL | toolkit/components/search/tests/xpcshell/test_sendSubmissionURL.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | toolkit/components/search/tests/xpcshell/test_sendSubmissionURL.js | test - [test : 48] "undefined" == "https://duckduckgo.com/?q="

Mike, what do we need to do to get this test for pass for Thunderbird, or should we just disable it?
Flags: needinfo?(mozilla)
Whiteboard: [Thunderbird-testfailure: X all]
Just disable it.
Flags: needinfo?(mozilla)
Actually, I think I need to fix this in the test.
Assignee: nobody → mozilla
Thanks for the quick feedback. Unless I've read the test incorrectly, it only fails on "Duck Duck Go" and passes on the others. Or is the map processed at random and "Duck Duck Go" comes first? We seem to have "Duck Duck Go" for some locales:
https://searchfox.org/comm-central/rev/70e13f0d1fb3dc48a6ddcb25ad4c2a18df63c608/mail/components/search/searchplugins/list.json#65
I think the problem is that in the code, I'm checking for www.duckduckgo instead of duckduckgo.

This works on Firefox because we have a second check for domains in our default search engines, so it passes there.

So I need to fix my stuff. I'm glad Thunderbird found this :).
As I stated before (bug 1334771 comment #73 and quoted occasionally): We're the "secondary testing brigade" ;-) - Many M-C bugs have shown up in TB first since our tests or our environment caught them.
Any chance to get this one-line-two-character change reviewed soon? Maybe some other reviewer is available.

Sorry about the impatience, but having currently three M-C test failures on our tree makes effective sheriffing hard and all people doing try runs need to ignore these failures, too.
Flags: needinfo?(mozilla)
Attachment #8998162 - Attachment is obsolete: true
Comment on attachment 8998162 [details]
Bug 1481420 - DuckDuckGo doesn't use subdomains.

Drew Willcoxon :adw has approved the revision.
Attachment #8998162 - Flags: review+
Attachment #8998162 - Attachment is obsolete: false
Sorry for the delay. I'll figure out the other one as well.
Flags: needinfo?(mozilla)
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/5373497f3c4e
DuckDuckGo doesn't use subdomains. r=adw
https://hg.mozilla.org/mozilla-central/rev/5373497f3c4e
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 63.0
Thanks Mike, that fixed the problem for us.
You need to log in before you can comment on or make changes to this bug.