CSS1 'width' not fully supported

RESOLVED INVALID

Status

()

RESOLVED INVALID
17 years ago
17 years ago

People

(Reporter: mangala, Assigned: attinasi)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    20020523

When box attributes including 'width' are applied to a TD element, the width
displays correctly.

However, when box attributes including 'width' are applied to an A (anchor)
element or plain text, the width does not display correctly.

The property should apply to text elements
(http://www.w3.org/TR/REC-CSS1#width).  The sample below displays correctly in
IE 5.5.

Reproducible: Always
Steps to Reproduce:
1. Assign a value for the 'width' attribute and apply it to an anchor or text
element.

Sample html below illustrates the problem:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd">
<html>
<head>
</head>
<body TEXT="000000" BGCOLOR="FFFFFF">

<table>
  <tr>
    <td STYLE="width: 250px; border: 1px solid black">Table cell</td>
  </tr>
</table>

<br>

<span style="width: 250px; border: 1px solid maroon">Not a table</span>

<br>

</body>
</html>
(Reporter)

Comment 1

17 years ago
Created attachment 85619 [details]
Test-case

Updated

17 years ago
QA Contact: petersen → amar
Quoting from the URL you cite:

  Applies to: block-level and replaced elements

Since <a> is an non-replaced inline element, "width" does not apply to it.  IE 
is just buggy.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.