Closed Bug 1481708 Opened 2 years ago Closed 2 years ago

run wasm-misc on desktop browsers

Categories

(Testing :: Raptor, enhancement)

enhancement
Not set

Tracking

(firefox63 fixed)

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: jmaher, Assigned: jmaher)

References

Details

Attachments

(1 file)

instead of running massive or asm.js benchmarks, we want to run wasm-misc benchmark on desktop browers.  This will run against firefox and chrome.

In addition, there will be 2 extra firefox modes:
baseline:
    javascript.options.wasm_baselinejit to true
    javascript.options.wasm_ionjit to false
ionmonkey:
    javascript.options.wasm_baselinejit to false
    javascript.options.wasm_ionjit to true
some initial work for the default view:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=66ed2ccc8476bd90e081b63cab221f9183f8dfd2

it produces numbers, but not processed and uploaded to perfherder, still working on that.
Blocks: 1482151
Duplicate of this bug: 1472987
support wasm-misc as a benchmark in raptor
Comment on attachment 9001998 [details]
Bug 1481708 - run wasm-misc on desktop browsers. r=rwood

Robert Wood [:rwood] has approved the revision.
Attachment #9001998 - Flags: review+
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2f1bbddc826b
run wasm-misc on desktop browsers. r=rwood
https://hg.mozilla.org/mozilla-central/rev/2f1bbddc826b
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Assignee: nobody → jmaher
You need to log in before you can comment on or make changes to this bug.