intl libraries depend on necko (unicharutil, locale, and uconv)

VERIFIED FIXED in mozilla1.1beta

Status

()

P2
normal
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: alecf, Assigned: alecf)

Tracking

({intl})

Trunk
mozilla1.1beta
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in hand)

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
ok, so I finally did some investigation to find out why all the i18n libraries
seem to depend on necko, and determined that they're all using necko just to
load a couple large .properties files into a nsIPersistentProperties object -
most of the code predates string bundles, and should be using string bundles
anyway.. both for easier code maintenance and for the bonuses that string
bundles provide, like caching and locale-awareness.

I fixed up unicharutil, uconv, and locale so that they no longer depend on
necko. chardet will probably have to depend on necko in order to do fancy
character detection on documents, and intl (string bundles) will continue to
depend on necko for the time being.

patch forthcoming.
(Assignee)

Comment 1

17 years ago
Created attachment 85631 [details] [diff] [review]
break necko dependencies

yeah, this cleans us up some.

Comment 2

17 years ago
Code issue, QA -> yokoyama.
Keywords: intl
QA Contact: ruixu → yokoyama
(Assignee)

Comment 3

17 years ago
oops, reassign to myself

roy / jag - can I get an r=/sr= on this patch? thanks!
Assignee: yokoyama → alecf
Blocks: 106686
Priority: -- → P2
Target Milestone: --- → mozilla1.1alpha

Comment 4

17 years ago
ftang should look at the patch.
ftang: Can you review?

cc ftang

Comment 5

17 years ago
If you don't mind, could you change ::GetService to do_GetService etc. where you
touch them? I'll look again after you get r= on this.
(Assignee)

Comment 6

17 years ago
mozilla 1.1alpha already passed, just moving out to 1.1beta
Status: NEW → ASSIGNED
Target Milestone: mozilla1.1alpha → mozilla1.1beta
(Assignee)

Comment 7

17 years ago
jag: I actually removed all instances but one, and that one I can't use
do_GetService, because its being stored in a global, raw pointer.

can you sr= this? Thanks...

Comment 8

17 years ago
Comment on attachment 85631 [details] [diff] [review]
break necko dependencies

sr=jag
Attachment #85631 - Flags: superreview+

Comment 9

17 years ago
Comment on attachment 85631 [details] [diff] [review]
break necko dependencies

The patch looks like not just remove the dependency of necko but some other
stuff. Can you break down rewrite into seperate bug/patch? I don't understand
moving some case conversion compress class has anything deal with necko at all.
(it could be a good thing to do but nothing to do with necko dependency,
right?) Also, what kind of test have you perform to prove your patch do no
evil?
(Assignee)

Comment 10

17 years ago
ok, I've tested the patch, by making sure that entities continue to work, etc...
as for the nsCompressedCharMap, I'll move that to another patch... new patch
coming up later today
Whiteboard: fix in hand
(Assignee)

Comment 11

17 years ago
ok, so coming back to this - the patch contains changes to nsCompressedMap, but
those changes are localized to nsCaseConvertionImp2.cpp and
nsCaseConversionImp2.h - if I don't check those in, can I review this? I have
run the usual regression tests, etc. 

In addition, if this patch didn't work, all entities would be broken in my
build, and thus all localized strings in the UI... which they aren't.

Frank, can I get that review now?

Comment 12

17 years ago
Comment on attachment 85631 [details] [diff] [review]
break necko dependencies

r=ftang
Attachment #85631 - Flags: review+
(Assignee)

Comment 13

17 years ago
cool. fix is in. thanks folks.
(Assignee)

Comment 14

17 years ago
oops, marking fixed this time.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 15

17 years ago
alec: Thanks for your help. :)  I see no necko linked in the makefiles

However, I see MOZ_NECKO_UTIL_LIBS in \uconv\src\makefil.in and
\unicharutil\src\makefile.in
I lxr'ed for MOZ_NECKO_UTIL_LIBS and 
http://lxr.mozilla.org/seamonkey/search?string=MOZ_NECKO_UTIL_LIBS
and it looks though it's a linux platform specific and not defined.  
Is it depreciated? (note, I searched the moz.org and returns nothing)

darin/ftang? do u know what MOZ_NECKO_UTIL_LIBS is used for?

Comment 16

17 years ago
i have no idea what MOZ_NECKO_UTIL_LIBS is used for.
(Assignee)

Comment 17

17 years ago
I think its a throwback to the days of a necko utility library which contained
NS_NewURL and friends (i.e. now inline in nsNetUtil.h) - it doesn't resolve to
anything, so its pretty harmless.

http://lxr.mozilla.org/seamonkey/search?string=moz_necko_util_libs

Comment 18

17 years ago
agreed, marking as VERIFIED.
unicharutil, locale, and uconv don't have necko dependency.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 143283
You need to log in before you can comment on or make changes to this bug.