Closed Bug 14819 Opened 21 years ago Closed 20 years ago

need to remove vestigial native menu code from widget/src/* (not mac)

Categories

(Core :: XUL, defect, P3)

x86
Other
defect

Tracking

()

VERIFIED DUPLICATE of bug 17027

People

(Reporter: hyatt, Assigned: rods)

Details

(Whiteboard: Fixes in my tree for WinNT)

We don't need this stuff anymore, and it's misleading to new porters and
maintainers.
Status: NEW → ASSIGNED
QA Contact: beppe → hyatt
Summary: need to remove vestigial native menu code from widget/src/* (not mac) → [HELP WANTED] need to remove vestigial native menu code from widget/src/* (not mac)
Target Milestone: M15
code-level fix, yadda yadda yadda
does this mean removing, nsMenu.cpp/h nsMenuBar.cpp/h and nsMenuItem.cpp/h from
the build, and removing the references to them?
does this mean removing, nsMenu.cpp/h nsMenuBar.cpp/h and nsMenuItem.cpp/h from
the build, and removing the references to them?
Yes, the files in widget... for win32 and linux, they don't need to be
there any more.
Assignee: hyatt → rods
Status: ASSIGNED → NEW
Here it is, Rod.  Thanks!
Status: NEW → ASSIGNED
Summary: [HELP WANTED] need to remove vestigial native menu code from widget/src/* (not mac) → need to remove vestigial native menu code from widget/src/* (not mac)
Whiteboard: Fixes in my tree for WinNT
Fixes in my tree for WinNT

*** This bug has been marked as a duplicate of 17027 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
VERIFY duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.