Closed Bug 1481918 Opened 2 years ago Closed Last year

Decouple addon studies lifecycle from addon lifecycle

Categories

(Firefox :: Normandy Client, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 63
Tracking Status
firefox63 --- fixed

People

(Reporter: aswan, Assigned: aswan)

References

Details

Attachments

(2 files)

This bug is meant to cover the Normandy-specific parts of https://github.com/mozilla/shield-studies-addon-utils/issues/246

To summarize:
Shield studies need to do "some stuff" when they end.  The shield team has been trying to make this work by doing work at the moment the study extension is uninstalled but this doesn't work very well for various reasons.

The plan is to instead have Normandy send an event to the extension when the study is ending.  Once this event has been sent, Normandy will uninstall the extension, however the extension may reply with a Promise in which case Normandy will wait until that Promise is resolved to start the uninstall.
This should wait until my current work to refactor the add-on study handling is done. I'll have a patch up soon.
Depends on: 1440780
(In the proposed plan, I worry about how to test that the Shield Addon responds correctly.  I am fine with a 'fire, wait, uninstall` if that works.)
Comment on attachment 9002249 [details]
Bug 1481918 Add an unenrollment hook for shield addon studies

Michael Cooper [:mythmon] has approved the revision.
Attachment #9002249 - Flags: review+
Comment on attachment 9002248 [details]
Bug 1481918 Allow webextension test wrappers for externally installed extensions

Kris Maglione [:kmag] has approved the revision.
Attachment #9002248 - Flags: review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/169b47aeda91a0122dcb491a501db4d4543b5e48
Bug 1481918 Allow webextension test wrappers for externally installed extensions r=kmag

https://hg.mozilla.org/integration/mozilla-inbound/rev/a8c76f3a18f9f6b57331aea619df59bc16552d24
Bug 1481918 Add an unenrollment hook for shield addon studies r=mythmon
https://hg.mozilla.org/mozilla-central/rev/169b47aeda91
https://hg.mozilla.org/mozilla-central/rev/a8c76f3a18f9
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Duplicate of this bug: 1456247
You need to log in before you can comment on or make changes to this bug.