Closed Bug 1482036 Opened Last year Closed Last year

Animation progress bar - playing past scroll bar

Categories

(DevTools :: Inspector: Animations, defect, P3)

defect

Tracking

(firefox-esr52 unaffected, firefox-esr60 wontfix, firefox61 wontfix, firefox62 wontfix, firefox63 verified)

VERIFIED FIXED
Firefox 63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- verified

People

(Reporter: cfogel, Assigned: daisuke)

References

Details

(Keywords: regression)

Attachments

(2 files)

[Affected versions]:
- 63.0a1 (2018-08-09), 62.0b14, 61.0.1, 60.1.0esr, 45.3.0ESR

[Affected platforms]:
- win10x64, macOS10.9, Ubuntu 16.04LTS

[Steps to reproduce]:
1. Launch Firefox;
2. Open DevTools - Inspector - Animations Tab;
3. Type "anim" in the Search/Adress bar;
4. Press Enter on the Keyboard;
5. Observe the progress bar for the animations.

[Expected result]:
- The animation progress bar is contained by the section

[Actual result]:
- The progress bar stops at the browser edge, not at the scroll bar for animations;

[Regression range]:
- between ffx_54.0b8 (15-May-2017 23:05) and ffx_55 releases

[Additional notes]:
- attached screen recording with the issue;
- 52.8.0esr, 52.0.2, 54.0b2 are not affected
Thank you for the reporting Cristi.
Do you mean that the problem is that the scrubber is over the scroll bar?
The scrubber will not stop since there is at least one animation whose iteration count is infinity.
Flags: needinfo?(cristian.fogel)
Yes. But it should stop being visible when it reaches the scrollbar (or not go over it).
Flags: needinfo?(cristian.fogel)
Okay, thanks, I understood!
Priority: -- → P3
Comment on attachment 9003712 [details]
Bug 1482036: Hold the position of indicator bar in percentage. r=gl

Gabriel [:gl] (ΦωΦ) has approved the revision.
Attachment #9003712 - Flags: review+
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f4f34fa31c24
Hold the position of indicator bar in percentage. r=gl
https://hg.mozilla.org/mozilla-central/rev/f4f34fa31c24
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
See Also: → 1487015
Verified on 63.0a1 (2018-08-28) over Windows 10x64, MacOS 10.12, Ubuntu 16.04LTS.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.