Closed Bug 1482064 Opened 2 years ago Closed 2 years ago

Intermittent /webdriver/tests/element_clear/clear.py | test_input_readonly[date] - UnknownErrorException: unknown error (500): Failed to convert data to an object

Categories

(Testing :: geckodriver, defect, P5)

Version 3
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1482029

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=192951992&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/dFy8n2RESsqtb5e4nndnbQ/runs/0/artifacts/public/logs/live_backing.log

[task 2018-08-09T08:36:34.514Z] 08:36:34     INFO - TEST-UNEXPECTED-FAIL | /webdriver/tests/element_clear/clear.py | test_input_readonly[date] - UnknownErrorException: unknown error (500): Failed to convert data to an object
[task 2018-08-09T08:36:34.515Z] 08:36:34     INFO - session = <Session 9814c21b-5e0e-4575-b5e7-100f7e274d11>, type = 'date'
[task 2018-08-09T08:36:34.515Z] 08:36:34     INFO - 
[task 2018-08-09T08:36:34.515Z] 08:36:34     INFO -     @pytest.mark.parametrize("type",
[task 2018-08-09T08:36:34.515Z] 08:36:34     INFO -                              ["number",
[task 2018-08-09T08:36:34.516Z] 08:36:34     INFO -                               "range",
[task 2018-08-09T08:36:34.516Z] 08:36:34     INFO -                               "email",
[task 2018-08-09T08:36:34.517Z] 08:36:34     INFO -                               "password",
[task 2018-08-09T08:36:34.517Z] 08:36:34     INFO -                               "search",
[task 2018-08-09T08:36:34.517Z] 08:36:34     INFO -                               "tel",
[task 2018-08-09T08:36:34.517Z] 08:36:34     INFO -                               "text",
[task 2018-08-09T08:36:34.517Z] 08:36:34     INFO -                               "url",
[task 2018-08-09T08:36:34.517Z] 08:36:34     INFO -                               "color",
[task 2018-08-09T08:36:34.518Z] 08:36:34     INFO -                               "date",
[task 2018-08-09T08:36:34.518Z] 08:36:34     INFO -                               "datetime",
[task 2018-08-09T08:36:34.518Z] 08:36:34     INFO -                               "datetime-local",
[task 2018-08-09T08:36:34.519Z] 08:36:34     INFO -                               "time",
[task 2018-08-09T08:36:34.519Z] 08:36:34     INFO -                               "month",
[task 2018-08-09T08:36:34.519Z] 08:36:34     INFO -                               "week",
[task 2018-08-09T08:36:34.519Z] 08:36:34     INFO -                               "file"])
[task 2018-08-09T08:36:34.520Z] 08:36:34     INFO -     def test_input_readonly(session, type):
[task 2018-08-09T08:36:34.520Z] 08:36:34     INFO -         session.url = inline("<input type=%s readonly>" % type)
[task 2018-08-09T08:36:34.520Z] 08:36:34     INFO - >       element = session.find.css("input", all=False)
[task 2018-08-09T08:36:34.521Z] 08:36:34     INFO - 
[task 2018-08-09T08:36:34.522Z] 08:36:34     INFO - session    = <Session 9814c21b-5e0e-4575-b5e7-100f7e274d11>
[task 2018-08-09T08:36:34.522Z] 08:36:34     INFO - type       = 'date'
[task 2018-08-09T08:36:34.522Z] 08:36:34     INFO - 
[task 2018-08-09T08:36:34.523Z] 08:36:34     INFO - tests/web-platform/tests/webdriver/tests/element_clear/clear.py:167: 
[task 2018-08-09T08:36:34.523Z] 08:36:34     INFO - _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
[task 2018-08-09T08:36:34.523Z] 08:36:34     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:20: in inner
[task 2018-08-09T08:36:34.523Z] 08:36:34     INFO -     return func(self, *args, **kwargs)
[task 2018-08-09T08:36:34.524Z] 08:36:34     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:312: in css
[task 2018-08-09T08:36:34.524Z] 08:36:34     INFO -     return self._find_element("css selector", selector, all)
[task 2018-08-09T08:36:34.525Z] 08:36:34     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:318: in _find_element
[task 2018-08-09T08:36:34.525Z] 08:36:34     INFO -     return self.session.send_session_command("POST", route, body)
[task 2018-08-09T08:36:34.525Z] 08:36:34     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:507: in send_session_command
[task 2018-08-09T08:36:34.525Z] 08:36:34     INFO -     return self.send_command(method, url, body)
This happens because of the crash of Firefox due to the assertion in `!js::gc::EdgeNeedsSweepUnbarrieredSlow(&tmp)`:

https://treeherder.mozilla.org/logviewer.html#?job_id=192951992&repo=mozilla-inbound&lineNumber=37211-37213

This makes it a duplicate of bug 1482029.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1482029
You need to log in before you can comment on or make changes to this bug.