Open Bug 14822 Opened 21 years ago Updated 10 years ago

Mouseover of label should call mouseover of associated widget

Categories

(Core :: General, enhancement, P3)

x86
Windows 95
enhancement

Tracking

()

REOPENED

People

(Reporter: bugs, Unassigned)

Details

Mousing over the label should call the mouseover handler for input. This lets
the user know they can also click the label, as well as the actual widget.

<label for="blah">Blah Label</label>
<html:input id="blah" type="radio" name="foo"/>

severity set to "enhancement" as this is just an aesthetic issue.
Assignee: trudelle → rods
reassigning to rods. rod, is this your area?
Assignee: rods → kmcclusk
Kevin, I think this is a dupilcate, you were just asking me about it.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 16810 ***
Status: RESOLVED → VERIFIED
verifying as a dup.
I'm pretty sure this is not a duplicate of bug 16810.

Bug 16810: "Clicking on the labels for radio buttons doesn't toggle the radio button."

But 14822 (this bug): "Mousing over the label should call the mouseover handler for input."

Notice the difference? Bug 16810 is about Clicking. But 14822 (this bug) is about Mouseover. 

The reporter of this bug has literally requested "mouseover" of a label to cause a mouseover event to fire on the associate widget. 

Such behavior would be undesirable for many cases and would be taking great liberty with existing behavior based DOM 2 Events.

However, it is possible that the reporter did not intend his words to be interpreted literally, as he followed the first sentence with: "This lets
the user know they can also click the label, as well as the actual widget."

Possibly, the reporter of this bug wanted not DOM mouseover event to fire, but to create a hover effect. of the control.

When the user moves pointer over a label, that action should trigger the "hover" effect that would have happened from moving the pointer over that label's input. 

The test code in example 1 can be changed to:

<label for="blah">Blah Label</label>
<input id="blah" type="radio" name="foo" onmouseover="alert(1)">

In IE8, moving the pointer over "Blah Label" will have the effect of highlighting the associated control (the radio in this example) but won't cause a mouseover event to fire at that element.

This behavior is desirable because it lets the user know that when then pointer is over the label, that clicking that label will activate the control.
Assignee: kmcclusk → nobody
Status: VERIFIED → REOPENED
Component: XUL → General
QA Contact: cmaximus → general
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.