Status

()

enhancement
P3
normal
RESOLVED DUPLICATE of bug 1526425
Last year
6 months ago

People

(Reporter: mgaudet, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 affected)

Details

In a similar manner to how the JS Opcodes have metadata, it would be useful to provide metadata on CacheIR ops. 

At minimum, the length would be incredibly useful to have. However I can also imagine use for information like whether or not the operand has a stub field or not.

It would simplify writing CacheIR parsing code like this [1], where the length is 'expected' but there's no way to assert or ensure this remains true outside of auditing. 


[1]: https://searchfox.org/mozilla-central/rev/aff5d4ad5d7fb2919d267cbc23b1d87ae3cf0110/js/src/jit/BaselineInspector.cpp#322-349
Oh-- other data you could collect: 

- Does the op fill in the result register
- If so, what type?
Priority: -- → P3

Forward duping to the more thoroughly thought through Bug 1526425

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1526425
You need to log in before you can comment on or make changes to this bug.