Closed Bug 1482255 Opened Last year Closed Last year

Default search shortcuts not getting pinned on first run

Categories

(Firefox :: New Tab Page, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.4 - Aug 20
Tracking Status
firefox62 --- verified
firefox63 --- verified

People

(Reporter: k88hudson, Assigned: ahillier)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

STR:

Run the browser with a new profile.

Expected:

Amazon and Google are pinned.

Actual:

Amazon and Google are not pinned, but get pinned on a subsequent top sites refresh.
Iteration: --- → 63.4 - Aug 20
Priority: -- → P2
Iteration: 63.4 - Aug 20 → ---
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Assignee: nobody → ahillier
Blocks: 1482205
https://hg.mozilla.org/mozilla-central/rev/972b3c48c6e9
Iteration: --- → 63.4 - Aug 20
Target Milestone: --- → Firefox 63
Blocks: 1482398
I have verified that the issue is no longer reproducible in the latest Nightly (63.0a1, Build ID 20180815225731) on Windows 10, Mac 10.13 and Linux x64. I haven't been able to find a build where this issue was reproducible so I'm pretty sure it never actually made it in Nightly builds.
Status: RESOLVED → VERIFIED
I have verified that the issue is not reproducible in the latest Firefox Beta (62.0b18 Build ID 20180816151750) on Windows 10, Mac 10.13 and Linux x64. Default Search Shortcuts are added on first run.
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.