Closed Bug 1482345 Opened 3 years ago Closed 3 years ago

256x256 icon not installed

Categories

(Thunderbird :: Theme, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(thunderbird_esr6062+ fixed, thunderbird62 wontfix, thunderbird63 fixed)

RESOLVED FIXED
Thunderbird 63.0
Tracking Status
thunderbird_esr60 62+ fixed
thunderbird62 --- wontfix
thunderbird63 --- fixed

People

(Reporter: exalm7659, Assigned: Paenglab)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.0 Safari/605.1.15 Epiphany/605.1.15



Actual results:

As can be seen at https://dxr.mozilla.org/comm-central/source/mail/branding/branding-common.mozbuild#23 , `default256.png` is not installed.


Expected results:

It should have been installed along with other icons.
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Component: Untriaged → Theme
Firefox also doesn't package the 256px icon. May I ask for what you need it and the 128px icon isn't enough?
This icon in displayed in application lists, particularly in GNOME Shell on HiDPI. 128x128 icon is too small for that, and looks blurred.

The best would be to have a 512x512 icon[1] or a scalable vector icon, but since a 256x256 icon is already available, in the meantime it could be good to use it at least.

If Firefox doesn't install a 256x256 icon, it should also do that.

[1]: https://developer.gnome.org/hig/stable/icons-and-artwork.html.en
Attached patch 256pxIcon.patchSplinter Review
We differ already with adding the symbolic icon from FX, so this should be okay to add.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8999271 - Flags: review?(jorgk)
Attachment #8999271 - Flags: approval-comm-esr60?
Attachment #8999271 - Flags: approval-comm-beta?
Comment on attachment 8999271 [details] [diff] [review]
256pxIcon.patch

Not tested ;-)
Attachment #8999271 - Flags: review?(jorgk)
Attachment #8999271 - Flags: review+
Attachment #8999271 - Flags: approval-comm-esr60?
Attachment #8999271 - Flags: approval-comm-esr60+
Attachment #8999271 - Flags: approval-comm-beta?
Attachment #8999271 - Flags: approval-comm-beta+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/12cead5f31a4
Install the 256px icon on Linux. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 63.0
Backout:
https://hg.mozilla.org/comm-central/rev/5ee4a1b9b6017d55a958de12010569d1386ad5b5

Looks like the list needs to be sorted alphabetically.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/574cd57f75d4
Install the 256px icon on Linux. r=jorgk
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Attachment #8999271 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.