Closed Bug 1482401 Opened 3 years ago Closed 3 years ago

Perma-failing devtools/client/debugger/new/test/mochitest/browser_dbg-console-async.js | Uncaught exception - waitFor - timed out after 500 tries when Gecko 63 merges to Beta on 2018-08-27

Categories

(DevTools :: Debugger, defect)

defect
Not set
normal

Tracking

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 unaffected, firefox63+ verified)

VERIFIED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 + verified

People

(Reporter: NarcisB, Assigned: aryx)

References

Details

Attachments

(2 files)

Central as beta simulation: 
https://treeherder.mozilla.org/#/jobs?repo=try&revision=aa761943ff5850ff3666094345bfa1edb568f516&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=usercancel&filter-resultStatus=runnable&filter-classifiedState=unclassified&selectedJob=193270410&filter-searchStr=dt

Failure log:

https://treeherder.mozilla.org/logviewer.html#?job_id=193265776&repo=try&lineNumber=1510


05:30:14     INFO - TEST-START | devtools/client/debugger/new/test/mochitest/browser_dbg-console-async.js
05:30:15     INFO - GECKO(1931) | [ACTION] ADD_SOURCES  - {"type":"ADD_SOURCES","sources":[{"id":"server1.conn12.child1/source25","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/script-switching-01.js","relativeUrl":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/script-switching-01.js","isPrettyPrinted":false,"isWasm":false,"sourceMapURL":null,"isBlackBoxed":false,"loadedState":"unloaded"}]}
05:30:15     INFO - GECKO(1931) | [ACTION] SET_WORKERS  - {"type":"SET_WORKERS","workers":[]}
05:30:15     INFO - GECKO(1931) | [ACTION] CONNECT  - {"type":"CONNECT","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/doc-script-switching.html","canRewind":false}
05:30:15     INFO - GECKO(1931) | [ACTION] ADD_SOURCES  - {"type":"ADD_SOURCES","sources":[{"id":"server1.conn12.child1/source26","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/script-switching-02.js","relativeUrl":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/script-switching-02.js","isPrettyPrinted":false,"isWasm":false,"sourceMapURL":null,"isBlackBoxed":false,"loadedState":"unloaded"}]}
05:30:15     INFO - GECKO(1931) | [ACTION] PAUSE_ON_EXCEPTIONS [start] - {"type":"PAUSE_ON_EXCEPTIONS","shouldPauseOnExceptions":false,"shouldPauseOnCaughtExceptions":true,"seqId":"1","status":"start"}
05:30:15     INFO - GECKO(1931) | [ACTION] PAUSE_ON_EXCEPTIONS [done] - {"type":"PAUSE_ON_EXCEPTIONS","shouldPauseOnExceptions":false,"shouldPauseOnCaughtExceptions":true,"seqId":"1","status":"done","value":{"from":"server1.conn12.child1/context23","type":"paused","actor":"server1.conn12.child1/pause27","poppedFrames":[],"why":{"type":"interrupted"}}}
05:30:15     INFO - GECKO(1931) | [ACTION] SET_EXPANDED_STATE  - {"type":"SET_EXPANDED_STATE","expanded":{}}
05:30:15     INFO - GECKO(1931) | [ACTION] SET_ORIENTATION  - {"type":"SET_ORIENTATION","orientation":"horizontal"}
05:30:15     INFO - GECKO(1931) | [ACTION] TOGGLE_ACTIVE_SEARCH  - {"type":"TOGGLE_ACTIVE_SEARCH","value":null}
05:30:15     INFO - GECKO(1931) | [ACTION] ADD_TAB  - {"type":"ADD_TAB","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/script-switching-01.js","tabIndex":0}
05:30:15     INFO - GECKO(1931) | [ACTION] SET_SELECTED_LOCATION  - {"type":"SET_SELECTED_LOCATION","source":{"id":"server1.conn12.child1/source25","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/script-switching-01.js","sourceMapURL":null,"isBlackBoxed":false,"isPrettyPrinted":false,"isWasm":false,"contentType":"","loadedState":"unloaded","relativeUrl":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/script-switching-01.js"},"location":{"sourceId":"server1.conn12.child1/source25"}}
05:30:16     INFO - GECKO(1931) | [ACTION] LOAD_SOURCE_TEXT [start] - {"type":"LOAD_SOURCE_TEXT","sourceId":"server1.conn12.child1/source25","seqId":"2","status":"start"}
05:30:16     INFO - GECKO(1931) | [ACTION] LOAD_SOURCE_TEXT [done] - {"type":"LOAD_SOURCE_TEXT","sourceId":"server1.conn12.child1/source25","seqId":"2","status":"done","value":{"id":"server1.conn12.child1/source25","text":"","contentType":"text/javascript"}}
05:30:16     INFO - GECKO(1931) | [ACTION] SET_SYMBOLS [start] - {}
05:30:16     INFO - GECKO(1931) | [ACTION] OUT_OF_SCOPE_LOCATIONS  - {}
05:30:16     INFO - GECKO(1931) | [ACTION] IN_SCOPE_LINES  - {}
05:30:16     INFO - GECKO(1931) | [ACTION] SET_SYMBOLS [done] - {}
05:30:16     INFO - GECKO(1931) | [ACTION] SET_PAUSE_POINTS  - {}
05:30:16     INFO - GECKO(1931) | [ACTION] SET_SOURCE_METADATA  - {"type":"SET_SOURCE_METADATA","sourceId":"server1.conn12.child1/source25","sourceMetaData":{}}
05:30:16     INFO - GECKO(1931) | [ACTION] ADD_SOURCES  - {"type":"ADD_SOURCES","sources":[{"id":"server1.conn12.child1/source28","url":"","relativeUrl":null,"isPrettyPrinted":false,"isWasm":false,"sourceMapURL":null,"isBlackBoxed":false,"loadedState":"unloaded"}]}
05:30:22     INFO - GECKO(1931) | Warning: getUnicodeUrl failed to get a Unicode URL fromdebugger eval code, reason: TypeError: debugger eval code is not a valid URL.
05:30:22     INFO - TEST-INFO | started process screencapture
05:30:22     INFO - TEST-INFO | screencapture: exit 0
05:30:22     INFO - Buffered messages logged at 05:30:14
05:30:22     INFO - Entering test bound 
05:30:22     INFO - Adding a new tab with URL: http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/doc-script-switching.html
05:30:22     INFO - Tab added and finished loading
05:30:22     INFO - Opening the toolbox
05:30:22     INFO - Buffered messages logged at 05:30:15
05:30:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
05:30:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
05:30:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
05:30:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
05:30:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
05:30:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
05:30:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
05:30:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
05:30:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
05:30:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
05:30:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
05:30:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
05:30:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
05:30:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
05:30:22     INFO - Toolbox opened and focused
05:30:22     INFO - Buffered messages logged at 05:30:16
05:30:22     INFO - Waiting for state change: selected source
05:30:22     INFO - Finished waiting for state change: selected source
05:30:22     INFO - TEST-PASS | devtools/client/debugger/new/test/mochitest/browser_dbg-console-async.js | Split console is shown. - 
05:30:22     INFO - TEST-PASS | devtools/client/debugger/new/test/mochitest/browser_dbg-console-async.js | Split console is shown. - 
05:30:22     INFO - Buffered messages finished
05:30:22     INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/new/test/mochitest/browser_dbg-console-async.js | Uncaught exception - waitFor - timed out after 500 tries.
05:30:22     INFO - Leaving test bound 
05:30:22     INFO - Removing tab.
05:30:22     INFO - Waiting for event: 'TabClose' on [object XULElement].
05:30:22     INFO - Got event: 'TabClose' on [object XULElement].
05:30:22     INFO - Tab removed and finished closing
Jason, seems to be caused by Bug 1481628. Can you please take a look?
Flags: needinfo?(jlaster)
[Tracking Requested - why for this release]:
Happy to look
Flags: needinfo?(jlaster)
yes, i'm not sure how it landed. I'll add a fix here which should land soon
https://bugzilla.mozilla.org/show_bug.cgi?id=1482406
This should now be fixed, is that the case?
It's not on beta but this doesn't matter because beta simulations use the code on central and simulate how beta will look like after the next merge day. Bug 1482406 got merged to central on Saturday, see bug 1482406 comment 6. Beta simulations are still affected by the issue after that.
okay, in that case we might want to disable the test in beta
Attached patch pull requestSplinter Review
Assignee: nobody → aryx.bugmail
Status: NEW → ASSIGNED
Attachment #9002068 - Flags: review?(jlaster)
Attachment #9002068 - Attachment is patch: true
Attachment #9002068 - Attachment mime type: text/x-github-pull-request → text/plain
Attachment #9002068 - Flags: review?(jlaster) → review+
This got merged into central with bug 1484972.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.