Closed Bug 1482486 Opened 2 years ago Closed 2 years ago

Intermittent testing\firefox-ui\tests\functional\safebrowsing\test_notification.py TestSafeBrowsingNotificationBar.test_notification_bar | application crashed [@ xul.dll + 0x2d9378f]

Categories

(Testing :: Firefox UI Tests, defect, P5, critical)

Version 3
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1482029

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: crash, intermittent-failure)

Crash Data

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=193324393&repo=mozilla-central

https://queue.taskcluster.net/v1/task/UW2JXwojTJCSZ3M-7CDFug/runs/0/artifacts/public/logs/live_backing.log

17:19:41     INFO - mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/Wu_ahIKsRSOBk_73N4NBxA/artifacts/public/build/target.crashreporter-symbols.zip
17:19:44     INFO - mozcrash Copy/paste: Z:\task_1533920855\build\win32-minidump_stackwalk.exe Z:\task_1533920855\build\tmpca_ccb.mozrunner\minidumps\992980dc-4234-4315-a5d8-bb9c39a70088.dmp c:\users\task_1533920855\appdata\local\temp\tmplbrubq
17:19:51     INFO - mozcrash Saved minidump as Z:\task_1533920855\build\blobber_upload_dir\992980dc-4234-4315-a5d8-bb9c39a70088.dmp
17:19:51     INFO - mozcrash Saved app info as Z:\task_1533920855\build\blobber_upload_dir\992980dc-4234-4315-a5d8-bb9c39a70088.extra
17:19:51     INFO - PROCESS-CRASH | testing\firefox-ui\tests\functional\safebrowsing\test_notification.py TestSafeBrowsingNotificationBar.test_notification_bar | application crashed [@ xul.dll + 0x2d9378f]
17:19:51     INFO - Crash dump filename: Z:\task_1533920855\build\tmpca_ccb.mozrunner\minidumps\992980dc-4234-4315-a5d8-bb9c39a70088.dmp
17:19:51     INFO - Operating system: Windows NT
17:19:51     INFO -                   6.1.7601 Service Pack 1
17:19:51     INFO - CPU: x86
17:19:51     INFO -      GenuineIntel family 6 model 63 stepping 2
17:19:51     INFO -      8 CPUs
17:19:51     INFO - 
17:19:51     INFO - GPU: UNKNOWN
17:19:51     INFO - 
17:19:51     INFO - Crash reason:  EXCEPTION_BREAKPOINT
17:19:51     INFO - Crash address: 0x5a2e378f
17:19:51     INFO - Assertion: Unknown assertion type 0x00000000
17:19:51     INFO - Process uptime: 15 seconds
17:19:51     INFO - 
17:19:51     INFO - Thread 0 (crashed)
17:19:51     INFO -  0  xul.dll + 0x2d9378f
17:19:51     INFO -     eip = 0x5a2e378f   esp = 0x001bcef8   ebp = 0x001bcf88   ebx = 0x001bcfc4
17:19:51     INFO -     esi = 0x001bcef8   edi = 0x0c764c40   eax = 0x6c3ae55c   ecx = 0x00000027
17:19:51     INFO -     edx = 0x6c2e8318   efl = 0x00200212
17:19:51     INFO -     Found by: given as instruction pointer in context
17:19:51     INFO -  1  xul.dll + 0x2d93001
17:19:51     INFO -     eip = 0x5a2e3001   esp = 0x001bcf90   ebp = 0x001bcf94
17:19:51     INFO -     Found by: previous frame's frame pointer
17:19:51     INFO -  2  xul.dll + 0x1316095
17:19:51     INFO -     eip = 0x58866095   esp = 0x001bcf9c   ebp = 0x001bd030
17:19:51     INFO -     Found by: previous frame's frame pointer
17:19:51     INFO -  3  xul.dll + 0x16f67f7
17:19:51     INFO -     eip = 0x58c467f7   esp = 0x001bd038   ebp = 0x001bd064
17:19:51     INFO -     Found by: previous frame's frame pointer
17:19:51     INFO -  4  xul.dll + 0x141993f
17:19:51     INFO -     eip = 0x5896993f   esp = 0x001bd06c   ebp = 0x001bd090
17:19:51     INFO -     Found by: previous frame's frame pointer
17:19:51     INFO -  5  xul.dll + 0xdcf790
17:19:51     INFO -     eip = 0x5831f790   esp = 0x001bd098   ebp = 0x001bd0f8
17:19:51     INFO -     Found by: previous frame's frame pointer
17:19:51     INFO -  6  xul.dll + 0x13102ad
17:19:51     INFO -     eip = 0x588602ad   esp = 0x001bd100   ebp = 0x001bd164
17:19:51     INFO -     Found by: previous frame's frame pointer
17:19:51     INFO -  7  xul.dll + 0x1685cc7
17:19:51     INFO -     eip = 0x58bd5cc7   esp = 0x001bd16c   ebp = 0x001bd198
17:19:51     INFO -     Found by: previous frame's frame pointer
17:19:51     INFO -  8  xul.dll + 0xca1b55
17:19:51     INFO -     eip = 0x581f1b55   esp = 0x001bd1a0   ebp = 0x001bd1d8
17:19:51     INFO -     Found by: previous frame's frame pointer
17:19:51     INFO -  9  xul.dll + 0x6c2c68
17:19:51     INFO -     eip = 0x57c12c68   esp = 0x001bd1e0   ebp = 0x001bd258
17:19:51     INFO -     Found by: previous frame's frame pointer
17:19:51     INFO - 10  xul.dll + 0x6e8c72
17:19:51     INFO -     eip = 0x57c38c72   esp = 0x001bd260   ebp = 0x001bd2d0
17:19:51     INFO -     Found by: previous frame's frame pointer
Crash Signature: [@ xul.dll + 0x2d9378f] → [@ xul.dll + 0x2d9378f] [@ xul.dll + 0x1f82e5a]
Crash Signature: [@ xul.dll + 0x2d9378f] [@ xul.dll + 0x1f82e5a] → [@ xul.dll + 0x2d9378f] [@ xul.dll + 0x1f82e5a] [@ JS_InitializePropertiesFromCompatibleNativeObject(JSContext*, JS::Handle<JSObject*>, JS::Handle<JSObject*>)]
No usable crash stack. Maybe related to bug 1482029 which happens kinda often those days.
Crash Signature: [@ xul.dll + 0x2d9378f] [@ xul.dll + 0x1f82e5a] [@ JS_InitializePropertiesFromCompatibleNativeObject(JSContext*, JS::Handle<JSObject*>, JS::Handle<JSObject*>)] → [@ xul.dll + 0x2d9378f] [@ xul.dll + 0x1f82e5a] [@ JS_InitializePropertiesFromCompatibleNativeObject(JSContext*, JS::Handle<JSObject*>, JS::Handle<JSObject*>)] [@ xul.dll + 0x915994]
Crash Signature: [@ xul.dll + 0x2d9378f] [@ xul.dll + 0x1f82e5a] [@ JS_InitializePropertiesFromCompatibleNativeObject(JSContext*, JS::Handle<JSObject*>, JS::Handle<JSObject*>)] [@ xul.dll + 0x915994] → [@ xul.dll + 0x2d9378f] [@ xul.dll + 0x1f82e5a] [@ JS_InitializePropertiesFromCompatibleNativeObject(JSContext*, JS::Handle<JSObject*>, JS::Handle<JSObject*>)] [@ xul.dll + 0x915994] [@ MOZ_CrashPrintf]
The debug build of Firefox clearly show the EdgeNeedsSweepUnbarrieredSlow assertion before the crash. As such I highly belief this is just another dupe of bug 1482029.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1482029
You need to log in before you can comment on or make changes to this bug.