Closed Bug 1482633 Opened Last year Closed Last year

Unexpected default pinned top search for various locale and region combinations

Categories

(Firefox :: New Tab Page, enhancement, P2)

enhancement

Tracking

()

RESOLVED INVALID
Iteration:
63.4 - Aug 20

People

(Reporter: Mardak, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Google and amazon get pinned but might need to be baidu and google ??

Maria, is there a document with the appropriate default pins?

https://download.mozilla.org/?product=firefox-nightly-latest-l10n-ssl&os=osx&lang=zh-CN

Array(6) [ "google", "bing", "baidu", "wikipedia-zh-CN", "amazondotcn", "ddg" ]

Also, @amazon doesn't actually work (as we don't want it for amazondotcn), but that's a separate bug 1482629.
Flags: needinfo?(mpopova)
Attached image no baidu default pinned
mkaply, I would guess this is because we do default pins based on geo/region. Because I'm testing zh-CN from US, it decides to pin google and amazon. What should the expected behavior be for zh-CN for various regions?

Here's what I see right now:

zh-CN/CN: google default search, baidu pinned top search
zh-CN/CA: google default search, google pinned top search
zh-CN/US: google default search, google and amazon pinned top search
Flags: needinfo?(mozilla)
Duplicate of this bug: 1482632
Summary: Wrong default top search for zh-CN → Unexpected default pinned top search for various locale and region combinations
From the other bug for ru / yandex:

attachment 8999356 [details] showing ru locale, US region

Google is pinned but not yandex. The default search engine shows up as google and is pinned.

Array(7) [ "google", "wikipedia-ru", "mailru", "yandex-ru", "ddg", "ozonru", "priceru" ]
What you see is exactly what I would expect. Default pins depend on region
Flags: needinfo?(mozilla)
So amazon should be pinned based on the desired region even though it's a different amazon? In this case it's amazon.cn for zh-CN/US, and a de/US user should have amazon.de pinned? Or those are different because amazondotcn does not have an alias but amazondotcom-de does get an alias? Or does a US region need to somehow use amazon.com?
> Or those are different because amazondotcn does not have an alias but amazondotcom-de does get an alias?

That's correct.

We should only pin things that have an internal alias. That's why I was explicit as to which amazons get mapped.

Right now we don't do region mapping of amazon like we do for eBay. It's on the todo list.
Okay, sounds like the defaults by region and nothing related to locale is expected. The amazon getting pinned or showing up as an organic top search is bug 1482629.
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(mpopova)
Resolution: --- → INVALID
Duplicate of this bug: 1483899
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.