From bug 1481693 comment 24: > You mentioned on IRC that there were issues if both `node` and `nodejs` exist: due to the way traversal works, we apparently search all paths for executable variant A before variant B. That means we could pick up a `nodejs` executable on a later path even if a sooner path had `node` available. > I don't think this is a deal breaker. But we may want to make check_prog() invert the traversal order by default or by request as a follow-up.
Comment on attachment 8999489 [details] [diff] [review] add pathsHavePriority option to check_prog for use with Node We do need this before we ask people to start testing, since otherwise they will be testing the wrong code and getting bogus results on Linux distros.
Attachment #8999489 - Flags: review?(gps)
Assignee: nobody → dmose
Status: NEW → ASSIGNED
Priority: -- → P1
Hmm, I've canceled that try job because there's infrastructure lossage going on, causing lots of false build failures.
OK, word on the street is that things are getting better, so here goes: https://treeherder.mozilla.org/#/jobs?repo=try&revision=67fae45898dd851964f13fca38924254efe34ee8
Comment on attachment 8999489 [details] [diff] [review] add pathsHavePriority option to check_prog for use with Node Review of attachment 8999489 [details] [diff] [review]: ----------------------------------------------------------------- r+ conditional on using the proper naming convention. ::: build/moz.configure/checks.configure @@ +102,5 @@ > # use that value instead. > @template > @imports(_from='mozbuild.shellutil', _import='quote') > def check_prog(var, progs, what=None, input=None, allow_missing=False, > + paths=None, pathsHavePriority=False, when=None): Names in Python use underscores. So this should be paths_have_priority.
Attachment #8999489 - Flags: review?(gps) → review+
Pushed by firstname.lastname@example.org: https://hg.mozilla.org/integration/mozilla-inbound/rev/e4da6d38fa33 configure should prefer .mozbuild copy of node
Attachment #8999489 - Attachment is obsolete: true
Comment on attachment 8999660 [details] [diff] [review] configure should prefer .mozbuild copy of node, v2 Naming convention fixed.
Attachment #8999660 - Flags: review+
You need to log in before you can comment on or make changes to this bug.