Closed Bug 1482817 Opened Last year Closed Last year

Closing attendee dialog by pressing the ok button doesn't work anymore

Categories

(Calendar :: Dialogs, defect)

Lightning 6.5
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: MakeMyDay, Assigned: darktrojan)

References

Details

(Keywords: regression, Whiteboard: [invite attendees dialog])

Attachments

(1 file, 1 obsolete file)

Closing the attendee dialog by pressing OK after adding an attendee doesn't work anymore. With no attendees added, the same works flawlessly. Regression from bug 1477478.

>TypeError: this.getRoleElement(...) is null[Learn More] calendar-event-dialog-attendees.xml:310:33
>  get_attendees         chrome://calendar/content/calendar-event-dialog-attendees.xml:310:33
>  onAccept              chrome://calendar/content/calendar-event-dialog-attendees.js:123:1
>  anonymous             chrome://global/content/bindings/dialog.xml line 404 > Function:3:8
>  _fireButtonEvent      chrome://global/content/bindings/dialog.xml:405:28
>  _doButtonCommand      chrome://global/content/bindings/dialog.xml:373:28
>  _handleButtonCommand  chrome://global/content/bindings/dialog.xml:361:18
>  editAttendees         chrome://lightning/content/lightning-item-iframe.js:1955:5
>  receiveMessage        chrome://lightning/content/lightning-item-iframe.js:190:31
Summary: Clsoing attendee by pressing the ok button doesn't work anymore → Closing attendee dialog by pressing the ok button doesn't work anymore
Attached patch 1482817-1482818-attendees-1.diff (obsolete) — Splinter Review
I'll fix this and bug 1482818 in one patch, since they are both tiny, essentially caused by the same thing, and it's easier than handling two patches.
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #8999553 - Flags: review?(philipp)
Attachment #8999553 - Flags: review?(philipp) → review?(makemyday)
Comment on attachment 8999553 [details] [diff] [review]
1482817-1482818-attendees-1.diff

Review of attachment 8999553 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, looks good.
Attachment #8999553 - Flags: review?(makemyday) → review+
N.B.: This will resolve bug 866504, of which bug 1482818 was a duplicate, too, when landing. Please set that to fixed (not duping since it's a separate issue then the scope of this bug).
Keywords: checkin-needed
Can you please provide a usable commit message. "Changes to DOM in attendees dialog causes broken behaviours" leaves more questions that it answers. Where was the DOM changed? What are you fixing? Maybe "Adapt attendee dialog to DOM changes from ???".

Also, please only one bug per commit message. I will mark bug 866504 as "fixed by bug 1482817".
Flags: needinfo?(geoff)
Attachment #8999553 - Attachment is obsolete: true
Flags: needinfo?(geoff)
Attachment #9003321 - Flags: review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/877d74ddb691
Fix broken attendee dialog behaviour caused by DOM changes in bug 1477478. r=MakeMyDay
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 6.5
You need to log in before you can comment on or make changes to this bug.