class names should be case sensitive

VERIFIED INVALID

Status

VERIFIED INVALID
17 years ago
13 years ago

People

(Reporter: ve3ll, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052306

Issue three of this bug tracking page shows a
problem where id class ID1 is assumed the same
as class id1.  The recommendation says case sensitivity
is on!  msie and opera also get this wrong.  one 
of the few places Amaya gets things right ;-]  ;-]
At one time you had this working but i suspect someone
wrote a make_all_upper function for something and it is 
being used where it should not be !!! 

Reproducible: Always
Steps to Reproduce:
1. View the test page
2. note that both lines are same effect
3. read style to see effects that should occur. 

Actual Results:  wrong style rule applied because of
bad assumption

Expected Results:  each line should have own style rule applied

Comment 1

17 years ago
Your suspicion is correct. It was decided that too many people just got this 
wrong on real web pages, and it would need to be supported in non-strict mode.

See bug 93371 and http://mozilla.org/docs/web-developer/quirks/ .
If you add a doctype such as "<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">"
then this will be handled per spec. See:
http://www.hixie.ch/tests/adhoc/css/selectors/class/001.html
http://www.hixie.ch/tests/adhoc/css/selectors/class/compatibility/001.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Verified that testing strict specification compliance in a page that is in 
quirks mode is pointless.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.