Closed Bug 1482854 Opened Last year Closed Last year

Middle clicking an @search Top Site wrongly triggers autoscroll

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.4 - Aug 20
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- verified
firefox63 --- verified

People

(Reporter: cmuresan, Assigned: ursula)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image autoscroll conflict.gif
[Affected versions]:
- Nightly v63.0a1, Build ID 20180812220618

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Steps to reproduce]:
1. Open the browser with a clean new profile.
2. Middle click a @search Top Site.
3. Observe the behavior.

[Expected results]:
- The @search term is autocompleted in the Address bar.

[Actual results]:
- The @search term is autocompleted in the Address bar but the autoscroll function is also triggered.

[Notes]:
- The escape key will no longer dismiss the contents of the Address bar after this.
- The issue is reproducible on Linux only with "general.autoScroll" set to true.
- Attached a screen recording of the issue.
Iteration: --- → 63.4 - Aug 20
Priority: -- → P3
Assignee: nobody → usarracini
Priority: P3 → P1
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/03d098de1d3ee85669f4a311c66ed2e54cb86255
Fix Bug 1482854 - Middle clicking an @search Top Site wrongly triggers autoscroll

https://github.com/mozilla/activity-stream/commit/93c6b1d00ebab91fcd633ccda8b2ed7adf00072f
Merge pull request #4332 from sarracini/bug_1482854

Fix Bug 1482854 - Middle clicking an @search Top Site wrongly triggers autoscroll
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Blocks: 1482959
Blocks: 1482398
I have verified that the issue is no longer reproducible in the latest Nightly (63.0a1, Build ID 20180816100035) on Windows 10, Mac 10.13 and Linux x64. Middle clicking a search Top Site no longer triggers the page to autoscroll.
Status: RESOLVED → VERIFIED
Fix verified on macOS 10.13, Ubuntu 116.04LTS, Windows 10x64 for Firefox 62.0b18.
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.