Closed Bug 1482871 Opened Last year Closed Last year

The Search Bar wrongly flashes blue when you click the area to the left or right of it

Categories

(Firefox :: New Tab Page, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.4 - Aug 20
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- verified
firefox63 --- verified

People

(Reporter: cmuresan, Assigned: rrosario)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

[Affected versions]:
- Nightly v63.0a1, Build ID 20180812220618

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Steps to reproduce]:
1. Open the browser with a clean new profile and open a new tab.
2. Click the area to the left or right of the Search bar.
3. Observe the behavior.

[Expected results]:
- The Search bar is focused and the text caret appears in it.

[Actual results]:
- The Search bar flashes as if focused and the text caret is not displayed in it.

[Notes]:
- Attached a screen recording of the issue.
Iteration: --- → 63.4 - Aug 20
Priority: -- → P3
Assignee: nobody → rrosario
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/253facc4ea285063d512c6c15d2db3cfa97ce500
Fix Bug 1482871 - remove blue flash when clicking on div.search-wrapper (#4325)
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Blocks: 1482959
Blocks: 1482398
I have verified that the issue is no longer reproducible in the latest Nightly (63.0a1, Build ID 20180816100035) on Windows 10, Mac 10.13 and Arch Linux x64.
Status: RESOLVED → VERIFIED
I managed to reproduce the issue using an older version of Nightly (2018-08-12) on Windows 10x64.
I retested everything using beta 62.0b19 on Windows 10 x64, Ubuntu 16.04 x64 and macOS 10.12. The bug is not reproducing anymore.
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.