Closed Bug 1482881 Opened Last year Closed Last year

Permafailing ccov Assertion failure: cx->isExceptionPending() (Thunk execution failed but no exception was raised - missing call to js::ReportOutOfMemory()?), at /builds/worker/workspace/build/src/js/src/builtin/TestingFunctions.cpp:1767

Categories

(Testing :: Code Coverage, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1483182

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure, regression)

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=193615259&repo=mozilla-central

https://queue.taskcluster.net/v1/task/QFsy4TQKRomhSypFDdpt_Q/runs/0/artifacts/public/logs/live_backing.log

[task 2018-08-13T11:31:57.516Z] 11:31:57     INFO -  TEST-PASS | tests/jit-test/jit-test/tests/gc/bug-1240503.js | Success (code 0, args "--baseline-eager") [1.3 s]
[task 2018-08-13T11:31:57.518Z] 11:31:57     INFO -  {"action": "test_start", "jitflags": "--baseline-eager", "pid": 14703, "source": "jittests", "test": "gc/bug-1240503.js", "thread": "main", "time": 1534159916.1691391}
[task 2018-08-13T11:31:57.519Z] 11:31:57     INFO -  {"action": "test_end", "extra": {"jitflags": "--baseline-eager", "pid": 14703}, "jitflags": "--baseline-eager", "message": "Success", "pid": 14703, "source": "jittests", "status": "PASS", "test": "gc/bug-1240503.js", "thread": "main", "time": 1534159917.511248}
[task 2018-08-13T11:31:57.738Z] 11:31:57     INFO -  [CodeCoverage] Setting handlers for process 14741.
[task 2018-08-13T11:31:57.740Z] 11:31:57     INFO -  Assertion failure: cx->isExceptionPending() (Thunk execution failed but no exception was raised - missing call to js::ReportOutOfMemory()?), at /builds/worker/workspace/build/src/js/src/builtin/TestingFunctions.cpp:1767
[task 2018-08-13T11:31:57.742Z] 11:31:57     INFO -  Exit code: -11
[task 2018-08-13T11:31:57.742Z] 11:31:57     INFO -  FAIL - gc/bug-1241731.js
[task 2018-08-13T11:31:57.744Z] 11:31:57  WARNING -  TEST-UNEXPECTED-FAIL | tests/jit-test/jit-test/tests/gc/bug-1241731.js | [CodeCoverage] Setting handlers for process 14741. (code -11, args "") [0.2 s]
[task 2018-08-13T11:31:57.744Z] 11:31:57     INFO -  {"action": "test_start", "jitflags": "", "pid": 14741, "source": "jittests", "test": "gc/bug-1241731.js", "thread": "main", "time": 1534159917.513717}
[task 2018-08-13T11:31:57.745Z] 11:31:57     INFO -  {"action": "test_end", "extra": {"jitflags": "", "pid": 14741}, "jitflags": "", "message": "[CodeCoverage] Setting handlers for process 14741.", "pid": 14741, "source": "jittests", "status": "FAIL", "test": "gc/bug-1241731.js", "thread": "main", "time": 1534159917.737742}
[task 2018-08-13T11:31:57.745Z] 11:31:57     INFO -  INFO exit-status     : -11
[task 2018-08-13T11:31:57.745Z] 11:31:57     INFO -  INFO timed-out       : False
[task 2018-08-13T11:31:57.745Z] 11:31:57     INFO -  INFO stderr         2> [CodeCoverage] Setting handlers for process 14741.
[task 2018-08-13T11:31:57.746Z] 11:31:57     INFO -  INFO stderr         2> Assertion failure: cx->isExceptionPending() (Thunk execution failed but no exception was raised - missing call to js::ReportOutOfMemory()?), at /builds/worker/workspace/build/src/js/src/builtin/TestingFunctions.cpp:1767
[task 2018-08-13T11:31:57.763Z] 11:31:57     INFO -  TEST-PASS | tests/jit-test/jit-test/tests/gc/bug-1240527.js | Success (code 0, args "--no-baseline --no-ion") [0.3 s]
[task 2018-08-13T11:31:57.764Z] 11:31:57     INFO -  {"action": "test_start", "jitflags": "--no-baseline --no-ion", "pid": 14730, "source": "jittests", "test": "gc/bug-1240527.js", "thread": "main", "time": 1534159917.409492}
[task 2018-08-13T11:31:57.765Z] 11:31:57     INFO -  {"action": "test_end", "extra": {"jitflags": "--no-baseline --no-ion", "pid": 14730}, "jitflags": "--no-baseline --no-ion", "message": "Success", "pid": 14730, "source": "jittests", "status": "PASS", "test": "gc/bug-1240527.js", "thread": "main", "time": 1534159917.759326}
[task 2018-08-13T11:31:58.276Z] 11:31:58     INFO -  TEST-PASS | tests/jit-test/jit-test/tests/gc/bug-1240527.js | Success (code 0, args "--baseline-eager") [0.9 s]
[task 2018-08-13T11:31:58.277Z] 11:31:58     INFO -  {"action": "test_start", "jitflags": "--baseline-eager", "pid": 14729, "source": "jittests", "test": "gc/bug-1240527.js", "thread": "main", "time": 1534159917.405054}
[task 2018-08-13T11:31:58.277Z] 11:31:58     INFO -  {"action": "test_end", "extra": {"jitflags": "--baseline-eager", "pid": 14729}, "jitflags": "--baseline-eager", "message": "Success", "pid": 14729, "source": "jittests", "status": "PASS", "test": "gc/bug-1240527.js", "thread": "main", "time": 1534159918.27268}
[task 2018-08-13T11:31:58.326Z] 11:31:58     INFO -  TEST-PASS | tests/jit-test/jit-test/tests/gc/bug-1241731.js | Success (code 0, args "--ion-eager --ion-offthread-compile=off") [0.6 s]
[task 2018-08-13T11:31:58.327Z] 11:31:58     INFO -  {"action": "test_start", "jitflags": "--ion-eager --ion-offthread-compile=off", "pid": 14747, "source": "jittests", "test": "gc/bug-1241731.js", "thread": "main", "time": 1534159917.740747}
[task 2018-08-13T11:31:58.327Z] 11:31:58     INFO -  {"action": "test_end", "extra": {"jitflags": "--ion-eager --ion-offthread-compile=off", "pid": 14747}, "jitflags": "--ion-eager --ion-offthread-compile=off", "message": "Success", "pid": 14747, "source": "jittests", "status": "PASS", "test": "gc/bug-1241731.js", "thread": "main", "time": 1534159918.322875}
[task 2018-08-13T11:31:58.327Z] 11:31:58     INFO -  TEST-PASS | tests/jit-test/jit-test/tests/gc/bug-1241731.js | Success (code 0, args "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.6 s]
[task 2018-08-13T11:31:58.327Z] 11:31:58     INFO -  {"action": "test_start", "jitflags": "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads", "pid": 14753, "source": "jittests", "test": "gc/bug-1241731.js", "thread": "main", "time": 1534159917.762842}
[task 2018-08-13T11:31:58.327Z] 11:31:58     INFO -  {"action": "test_end", "extra": {"jitflags": "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads", "pid": 14753}, "jitflags": "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads", "message": "Success", "pid": 14753, "source": "jittests", "status": "PASS", "test": "gc/bug-1241731.js", "thread": "main", "time": 1534159918.323906}
[task 2018-08-13T11:31:58.559Z] 11:31:58     INFO -  [CodeCoverage] Setting handlers for process 14761.
[task 2018-08-13T11:31:58.559Z] 11:31:58     INFO -  Assertion failure: cx->isExceptionPending() (Thunk execution failed but no exception was raised - missing call to js::ReportOutOfMemory()?), at /builds/worker/workspace/build/src/js/src/builtin/TestingFunctions.cpp:1767
[task 2018-08-13T11:31:58.559Z] 11:31:58     INFO -  Exit code: -11
Component: JavaScript Engine → Code Coverage
Flags: needinfo?(gmierz2)
Product: Core → Testing
Summary: Permafailing tier 2 Assertion failure: cx->isExceptionPending() (Thunk execution failed but no exception was raised - missing call to js::ReportOutOfMemory()?), at /builds/worker/workspace/build/src/js/src/builtin/TestingFunctions.cpp:1767 → Permafailing ccov Assertion failure: cx->isExceptionPending() (Thunk execution failed but no exception was raised - missing call to js::ReportOutOfMemory()?), at /builds/worker/workspace/build/src/js/src/builtin/TestingFunctions.cpp:1767
Looks like this was caused by these patches based on what I've found so far, it removes quite a few ReportOutOfMemory calls as well:
(1): https://hg.mozilla.org/mozilla-central/rev/6bb61989d9ae6611277918cbf320e878c55dd825
(2): https://hg.mozilla.org/mozilla-central/rev/223884f0ad76f8224f046311dd016b83fbb3aa6e
(3): https://hg.mozilla.org/mozilla-central/rev/ad30dc53e38ec41adc99f81fd8a5102ecf7775fd

I'll continue looking into it. :marco, do you have any thoughts on this?
Flags: needinfo?(mcastelluccio)
:njn, do you think those patches could have caused this test to start failing?
Flags: needinfo?(mcastelluccio) → needinfo?(n.nethercote)
Yes, those patches are at fault. The good news is that I will shortly land a fix in bug 1483182.
Blocks: 1481998
Flags: needinfo?(n.nethercote)
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1483182
Flags: needinfo?(gmierz2)
You need to log in before you can comment on or make changes to this bug.