Open Bug 1482896 Opened 2 years ago Updated 1 year ago

Browser compatibility for translate attribute incorrect

Categories

(Developer Documentation :: HTML, defect, P1)

All
Other
defect

Tracking

(Not tracked)

REOPENED

People

(Reporter: ishida, Assigned: wbamberg)

References

()

Details

:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: jwhitlock@mozilla.com

:: Details

https://developer.mozilla.org/en-US/docs/Web/HTML/Global_attributes/translate

Browser compatibility for the HTML translate attribute shows 'No support' across the board. I don't know the reason for that.  The translate attribute is effective for preventing translation by major online services and translation applications, regardless of browser used, but the translate mode of an element is also recognised by Chrome & Safari.

For more information, see 
https://www.w3.org/International/questions/qa-translate-flag
https://w3c.github.io/i18n-tests/results/translation-services
https://w3c.github.io/i18n-tests/results/the-translate-attribute

Please fix so that authors are not discouraged from using this attribute. It is important for localisation.

I can be contacted at ishida@w3.org.

(PS: It's surprisingly hard to raise an issue against that page. I was expecting a simple click to take me to a feedback page. I persevered, but thought of abandoning the feedback more than once, and rather regret the time it has taken me. I will be unlikely to provide further feedback in future.)
Assignee: nobody → fscholz
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Priority: P2 → P1
Assignee: fscholz → wbamberg

I've updated the compat for this attribute to be correct as far as I can tell from the available sources, and added some stronger encouragment to use it, and linked to the very useful w3c page.

https://developer.mozilla.org/en-US/docs/Web/HTML/Global_attributes/translate

I'm marking this as fixed but please let me know if you see anything else we should add here. And I'm sorry we took so long to get to this.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Thanks for your work on this. I'm still a little concerned that the Browser Compatibility section doesn't give the right impression unless you have clearly understood the text at the top of the page.

This attribute is a bit of an odd fish, and the compat section only provides an indication about whether it's possible to script the translate attribute, which is not really core to its intended use.

Can we add a note along the following lines to the compat section?

"The table only shows whether a browser can interact with the translate attribute via scripting. The core use of the attribute is, however, respected by automatic translation systems such as Google Translate, and is useful for human translators."

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Since this seems to be a lot about how we should represent things in the BCD, I filed https://github.com/mdn/browser-compat-data/issues/3600, where it might get more attention.

You need to log in before you can comment on or make changes to this bug.