Fails to display attachment sent from Apple Mail

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: bds02, Assigned: mscott)

Tracking

Trunk
PowerPC
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
No crash, just fails to tell me that the message has an attachment.

The sender is Apple Mail (2.481) which was running on MacOS X.
(Reporter)

Comment 1

17 years ago
Created attachment 85702 [details]
This is an email message containing an attachment which mozilla fails to display.

Updated

16 years ago
QA Contact: trix → yulian
QA Contact: yulian → stephend

Comment 2

15 years ago
The MIME structure of the message attached to this bug is not formed exactly as 
I would have expected. It is:
 Msg: multipart/alternative
  P1: text/plain         (plain-text text, textual "Attachment" note, and sig)
  P2: multipart/mixed
    P2.1: text/enriched  (rich-text version of the text)
    P2.2: application/pdf
    P2.3: text/enriched  (rich-text version of the sig)

I would have expected:
 Msg: multipart/mixed
  P1: multipart/alternative
    P1.1: text/plain
    P1.2: text/enriched  (text and sig in one part, thank you very much)
  P2: application/pdf

I suspect that Reporter originally was seeing only the first, text/plain part of 
the message -- which doesn't *contain* an attachment.

At any rate, when I integrate the (600K!) message from this bug into my Mozilla 
mail, I see three attachments: "Part 1.1.1" (text/enriched), the PDF file, and 
"Part 1.1.3" (text/enriched).  Since the multipart/mixed part is text/enriched 
rather than text/html, the "View|Message Body As" setting has no effect on the 
display of this message.

I'm marking this bug WorksForMe, but I've only checked on a Win2K system; if 
this is continuing to not work correctly on Linux (or MacOSX?) please feel free 
to reopen, with details please.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 3

15 years ago
See bug 234980, about how the 'text/enriched' parts are listed in the attachment 
panel as well as in the message body itself.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.