Closed Bug 1483153 Opened 2 years ago Closed 2 years ago

Let menulist popups inherit the font from their menulist parent

Categories

(Toolkit :: Themes, defect, P1)

All
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- fixed

People

(Reporter: dao, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(1 file)

(In reply to Stefan [:stefanh] from bug 1481754 comment #9)
> It looks like
> https://hg.mozilla.org/mozilla-central/diff/1c63d5a13deb/toolkit/themes/osx/
> global/menu.css#l1.98 and
> https://hg.mozilla.org/mozilla-central/diff/1c63d5a13deb/toolkit/themes/osx/
> global/menu.css#l1.77 made menuitems in menulists use -moz-pull-down-menu.
> The reason for the 'inherit' was to use the the same font as the menulist
> itself (which normally inherit the font from the parent). You can see the
> effect in the clear history menulist.
Attached patch patchSplinter Review
Attachment #8999861 - Flags: review?(stefanh)
Attachment #8999861 - Flags: review?(stefanh) → review+
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1197612113fc
Let menulist popups inherit the font from their menulist parent. r=stefanh
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/1197612113fc
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
See Also: → 1485867
You need to log in before you can comment on or make changes to this bug.