Closed Bug 1483165 Opened 2 years ago Closed 2 years ago

Crash in java.lang.NullPointerException: Attempt to invoke virtual method 'java.lang.Integer android.widget.TimePicker.getCurrentHour()' on a null object reference at org.mozilla.gecko.prompts.PromptInput$DateTimeInput.getValue(PromptInput.java)

Categories

(Firefox for Android :: Theme and Visual Design, defect, critical)

Unspecified
Android
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox61 --- unaffected
firefox62 --- verified
firefox63 --- verified

People

(Reporter: oana.horvath, Assigned: petru)

References

Details

(Keywords: crash)

Crash Data

Attachments

(2 files)

This bug was filed from the Socorro interface and is
report bp-6ac2c432-727e-471e-9e30-2e9d20180814.
=============================================================

Top 10 frames of crashing thread:

0 libxul.so GeckoAppShellSupport::ReportJavaCrash widget/android/nsAppShell.cpp:283
1 dalvik-main space (deleted) dalvik-main space @0x19579e 
2 libxul.so void mozilla::jni::NativeStub<mozilla::java::GeckoAppShell::ReportJavaCrash_t, GeckoAppShellSupport, mozilla::jni::Args<mozilla::jni::Ref<mozilla::jni::TypedObject<_jthrowable*>, _jthrowable*> const&, mozilla::jni::StringParam const&> >::Wrap<&GeckoAppShellSupport::ReportJavaCrash> widget/android/jni/Natives.h:778
3 dalvik-alloc space (deleted) dalvik-alloc space @0x122ce 
4 data@app@org.mozilla.firefox_beta-2@base.apk@classes.dex data@app@org.mozilla.firefox_beta-2@base.apk@classes.dex@0x1019f89 
5 dalvik-alloc space (deleted) dalvik-alloc space @0x1088e 
6 dalvik-main space (deleted) dalvik-main space @0x6dffe 
7 dalvik-main space (deleted) dalvik-main space @0x19579e 
8 dalvik-main space (deleted) dalvik-main space @0x1a50be 
9 dalvik-main space (deleted) dalvik-main space @0x1a50be 

=============================================================

Devices:
Mi 4i (Android 5.0.2)

Build: 
Nightly 63.0a1 (2018-07-26);
Beta 62.0b17

Steps to reproduce:
1. Go to https://www.456bereastreet.com/lab/html5-input-types/
2. Tap the Time and Date pickers.
*3. If it doesn't crash, check the font colors.

Expected result:
Date/time pickers should look like this: https://bug1412518.bmoattachments.org/attachment.cgi?id=8923292

Actual result:
The crash occurs on a Mi 4i (Android 5.0.2).

On Huawei MediaPad M2 (Android 5.1.1) there is no crash but the text is not visible, the pop-ups are messed-up. (see screenshots)

No issues on other devices, like Galaxy Note 8 (Android 8.0), Huawei P9 Lite (Android 6.0), Nokia 6 (Android 7.1.1), Oneplus Two (Android 6.0.1), Prestigio Grace X5 (Android 4.4.2)

Both issues lead to the same regression range:

build_date: 2018-07-26 

Pushlog: 
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e6d8a8e93db23de77e132d2eca68a5cbd61a679a&tochange=3f362dfcc16039bd81c171d039e39f3cbf64d003

Bug 1412518 - Photon themed DatePicker; r=jchen

On Api >=21 the Material DatePicker will have applied a Photon style.
Below Api 21 DatePicker will still be using spinners.

MozReview-Commit-ID: LuWP6C1o4Ej
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
Crash happened only on Lollipop because the new styles for the Photon theme are not properly supported at that API level.
Should be fixed by the patch for bug 1486200. Please recheck.
Flags: needinfo?(oana.horvath)
Verified as fixed on Nightly 63 (2018-08-30), along with bug 1486200.
Mi 4i (Android 5.0.2).
Huawei MediaPad M2 (Android 5.1.1)
Flags: needinfo?(oana.horvath)
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Depends on: 1486200
Target Milestone: --- → Firefox 63
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.